D - Hexadecimal View HDU - 4054(模拟)进制转换

Hexadecimal is very important and useful for computer programmers. You are requested to provide a hexadecimal view for given data. The hexadecimal view is made up of one or more rows. Every row except the last one represents 16 characters. Each row consists of three columns separated by a space: 

* addr: the 4-digit hexadecimal beginning address of this row. 
* dump: the hexadecimal representation of this row, separating every two characters by a whitespace. If there are less than 16 characters in the last row, pad it with spaces. 
* text: the ASCII translation of this row, with uppercase characters converted to lowercase and lowercase characters converted to uppercase. 
Use lowercase for the letter digits. See sample for more details. 
Input
There are multiple test cases. Each line is a test case. The line is made up of no less than 1 and no more than 4096 printable characters including spaces. 
Output
For each test case, output its hexadecimal view. Do not output any extra spaces after the last character of text. 
Sample Input
Hex Dump
#include <cstdio>
printf("Hello, World!\n");
main = do getLine >>= print . sum . map read . words
Sample Output
0000: 4865 7820 4475 6d70                     hEX dUMP
0000: 2369 6e63 6c75 6465 203c 6373 7464 696f #INCLUDE <CSTDIO
0010: 3e                                      >
0000: 7072 696e 7466 2822 4865 6c6c 6f2c 2057 PRINTF("hELLO, w
0010: 6f72 6c64 215c 6e22 293b                ORLD!\N");
0000: 6d61 696e 203d 2064 6f20 6765 744c 696e MAIN = DO GETlIN
0010: 6520 3e3e 3d20 7072 696e 7420 2e20 7375 E >>= PRINT . SU
0020: 6d20 2e20 6d61 7020 7265 6164 202e 2077 M . MAP READ . W
0030: 6f72 6473                               ORDS

输出分三列。 
第一列 : 0000: 表示当前语句的第1行 0010:表示当前语句的第二行。 以为规定一行只能输出16个字节, 所以代码中的一行可能要多行输出。 比如 该行代码一行有110字节 110 = 6 * 16 + 14就要输出 06e0: 
第二列: 一个字节8位, 一个16进制的数 4位, 所以每两个 16进制数就代表一个字符。 
不满16个字节,要输出空格。 
第三列: 把代码的的大小写互换。 每16个就要换行, 输出完一行代码也要换行(后面无多余的空格)。 
列与列之间有一个空格。

利用%04x 可以把数字。字符转化为16进制直接输出。

char s[50000+10];
char get_(char a)
{
    if(a>='a' && a<='z') return char(a-32);
    else if(a>='A' && a<='Z') return char(a+32);
    return a;
}
int main()
{
    ios::sync_with_stdio(false);
    while(gets(s))
    {
        int len=strlen(s);
        for(int i=0;i<len;i+=16)
        {
            if(i%16==0)
                printf("%04x:",i);
            int ans=0;
            for(int j=i;j<i+16 && j<len;j++)
            {
                if(j%2==0) printf(" %02x",s[j]);
                else printf("%02x",s[j]);
                ans++;
            }
            int t=ans%2;
            if(t)
            {
                cout<<"  ";
                ans++;
            }
            while(ans<16)
            {
                cout<<"     ";
                ans+=2;
            }
            cout<<' ';
            for(int j=i;j<i+16 && j<len;j++)
                putchar(get_(s[j]));
            cout<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值