PTA1002A+B for Polynomials

8 篇文章 0 订阅

PTA 1002A+B for Polynomials

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample output

3 2 1.5 1 2.9 0 3.2

这题我在看的时候一开始没看懂什么意思(英语太差了),其实很简单,第一行的输入代表:2(个数)1(指数)2.4(系数)0(指数)3.2(系数),第二行的输入也是一样,把两行输入中,指数相同的系数相加再按指数从大到小输出即可

上代码

#include "iostream"
using namespace std;
int main(){
    int num1, num2, totalNum = 0;
    double array1[1010] = {0};
    double array2[1010] = {0};
    cin >> num1;
    for(int i = 0;i<num1;i++){
        int exponent;
        double coefficient;
        cin>>exponent>>coefficient;
        array1[exponent] += coefficient;
    }
        
    cin >> num2;
    for(int i = 0;i<num2;i++){
        int exponent;
        double coefficient;
        cin>>exponent>>coefficient;
        array1[exponent] += coefficient;
    }
    
    for(int i = 0; i < 1010; i++){
        if(array1[i] != 0 && array2[i] != 0){
            array1[i] = array1[i] + array2[i];
        }
        
        if(array2[i] != 0 && array1[i] == 0){
            array1[i] = array2[i];
        }
    }
    for(int i = 0; i < 1009;i++)
        if(array1[i] !=0)
            totalNum++;
    cout<< totalNum;
    for(int i = 1009;i>=0;i--)
        if(array1[i] != 0)
            printf(" %d %.1f",i,array1[i]);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值