Jin Ge Jin Qu hao

(If you smiled when you see the title, this problem is for you ^_^)


For those who don’t know KTV, see: http://en.wikipedia.org/wiki/Karaoke_box


There is one very popular song called Jin Ge Jin Qu(). It is a mix of 37 songs, and is extremely
long (11 minutes and 18 seconds) — I know that there are Jin Ge Jin Qu II and III, and some other unofficial versions. But in this problem please forget about them.


Why is it popular? Suppose you have only 15 seconds left (until your time is up), then you should
select another song as soon as possible, because the KTV will not crudely stop a song before it ends (people will get frustrated if it does so!). If you select a 2-minute song, you actually get 105 extra seconds! ....and if you select Jin Ge Jin Qu, you’ll get 663 extra seconds!!!


Now that you still have some time, but you’d like to make a plan now. You should stick to the
following rules:


• Don’t sing a song more than once (including Jin Ge Jin Qu).


• For each song of length t, either sing it for exactly t seconds, or don’t sing it at all.


• When a song is finished, always immediately start a new song.


Your goal is simple: sing as many songs as possible, and leave KTV as late as possible (since we have rule 3, this also maximizes the total lengths of all songs we sing) when there are ties.


Input
The first line contains the number of test cases T (T ≤ 100). Each test case begins with two positive integers n, t (1 ≤ n ≤ 50, 1 ≤ t ≤ 109), the number of candidate songs (BESIDES Jin Ge Jin Qu) and the time left (in seconds). The next line contains n positive integers, the lengths of each song, in seconds. Each length will be less than 3 minutes — I know that most songs are longer than 3 minutes. But don’t forget that we could manually “cut” the song after we feel satisfied, before the song ends. So here “length” actually means “length of the part that we want to sing”.


It is guaranteed that the sum of lengths of all songs (including Jin Ge Jin Qu) will be strictly larger
than t.


Output
For each test case, print the maximum number of songs (including Jin Ge Jin Qu), and the total lengths of songs that you’ll sing.


Explanation:
In the first example, the best we can do is to sing the third song (80 seconds), then Jin Ge Jin Qu
for another 678 seconds.
In the second example, we sing the first two (30+69=99 seconds). Then we still have one second
left, so we can sing Jin Ge Jin Qu for extra 678 seconds. However, if we sing the first and third song instead (30+70=100 seconds), the time is already up (since we only have 100 seconds in total), so we can’t sing Jin Ge Jin Qu anymore!


Sample Input
2
3 100
60 70 80
3 100
30 69 70


Sample Output
Case 1: 2 758
Case 2: 3 777

思路:

01背包问题,动态规划。

稍微改一点的就是二维数组改成一维数组,数组里的数就相当于是背包里的物品数目。

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int N=1e6+5;
int t0,n;
int t;
int f[N];
int main()
{
	scanf("%d",&t0);
	for(int i=1;i<=t0;i++)
	{
		memset(f,-1,sizeof(f));
		scanf("%d %d",&n,&t);
		f[0]=0;
		int hh;
		for(int j=1;j<=n;j++)
		{
			scanf("%d",&hh);
			for(int k=t-1;k>=hh;k--)
			{
				f[k]=max(f[k],f[k-hh]+1);//(这首歌不唱即不变,这首歌唱和上一次比+1)
				//转移方程 
			}
		}
		int ans=t-1;
		for(int j=ans;j>=0;j--)
		{  	//选择唱歌数最大 
			if(f[j]>f[ans])
				ans=j;
			//printf("%d %d\n",ans,f[ans]);
		}
		printf("Case %d: %d %d\n",i,f[ans]+1,ans+678);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

TherAndI

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值