HDU 3549 Flow Problem 网络流 EK

Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

Author
HyperHexagon
 

Source



就是网络流的裸题。
这回练一下EK。。说实话EK真的好懂又好写。。
就是不停广搜找增广路,找到之后流量都减一遍,直到找不到增广路就好了。
可惜O(V*E^2)有局限。。稀疏图真的不错的。
其实这题也可以用EK做:poj1273


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 1005
using namespace std;
int n,m;
bool visit[N];
int map[N][N];
int Q[N],pre[N];
bool EdKa(int src,int des,int n)
{
    int v,i,head,tail;
    memset(visit,0,sizeof(visit));
    head=tail=0;
    Q[tail++]=src;
    visit[src]=true;
    while (head!=tail)
    {
        v=Q[head++];
        for (i=1;i<=n;i++)
            if (!visit[i] && map[v][i])
            {
                Q[tail++]=i;
                visit[i]=true;
                pre[i]=v;
                if (i==des)    return true;
            }
    }
    return false;
}
int maxflow(int src,int des,int n)
{
    int i,_min,sum=0;
    while (true)
    {
        if (!EdKa(src,des,n))
            return sum;
        _min=(1<<30);
        i=des;
        while (i!=src)
        {
            if (_min>map[pre[i]][i])
                _min=map[pre[i]][i];
            i=pre[i];
        }
        i=des;
        while (i!=src)
        {
            map[pre[i]][i]-=_min;
            map[i][pre[i]]+=_min;
            i=pre[i];
        }
        sum+=_min;
    }
}
int main()
{
    int T,cas;
    scanf("%d",&T);
    for (cas=1;cas<=T;cas++)
    {
        memset(map,0,sizeof(map));
        int x,y,z,j;
        scanf("%d%d",&n,&m);
        for (j=1;j<=m;j++)
        {
            scanf("%d%d%d",&x,&y,&z);
            map[x][y]+=z;
        }
        printf("Case %d: %d\n",cas,maxflow(1,n,n));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值