【ZOJ】zoj 1047 (bfs)

</pre><pre name="code" class="cpp"><pre name="code" class="cpp"><div class="hiddable" id="vj_description" style="font-family: 'times new roman'; font-size: 17px; color: rgb(51, 51, 51);"><p class="pst" style="font-family: Arial, Helvetica, sans-serif; font-size: 18pt; font-weight: bold; color: blue; margin-bottom: 0px;">Description</p><div class="textBG" style="border-top-left-radius: 10px; border-top-right-radius: 10px; border-bottom-right-radius: 10px; border-bottom-left-radius: 10px; padding: 10px; border-style: dotted; border-width: 2px; background-color: rgb(234, 235, 255);"><div class="ptx" lang="en-US" style="font-family: 'Times New Roman', Times, serif; font-size: 12pt;">Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects. 

The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are 
<pre style="white-space: pre-wrap; word-wrap: break-word;">XX   Grid 1       .XXX   Grid 2 
XX                .XXX 
                  .XXX 
                  ...X 
                  ..X. 

 X... 


An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected. 

 

XXX 
XXX    Central X and adjacent X's 
XXX 


An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object. 

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3. 

 

 


One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18. 

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear: 

 

Impossible   Possible 

XXXX         XXXX   XXXX   XXXX 
X..X         XXXX   X...   X... 

XX.X         XXXX   XX.X   XX.X 
XXXX         XXXX   XXXX   XX.X 

.....        .....  .....  ..... 

..X..        ..X..  ..X..  ..X.. 

.X.X.        .XXX.  .X...  ..... 

..X..        ..X..  ..X..  ..X.. 

.....        .....  .....  ..... 

 

Input

The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters. 

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks. 

Output

For each grid in the input, the output contains a single line with the perimeter of the specified object.

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0

Sample Output

8
18
40
48
8
 
</pre><pre name="code" class="cpp">题目的意思:先输入行数 row 和列数 col,然后输入搜索起点的坐标,下面输入<span style="font-family: Arial, Helvetica, sans-serif;">一个由“X”和“.”组成的行数为row,列数为col矩形,求解以搜索起点和它的八个方向连接的“X”,组成的图形的周长。</span>
这个题目是一个宽度优先搜索,通过宽度优先搜索可以搜到联通区域,计算周长可以通过他是否是边界,或者是否周围有‘.’,然后让计数的变量自增。
代码:
<pre name="code" class="cpp">#include <iostream>
#include<algorithm>
#include<cstdio>
#include<stdio.h>
#include<queue>
#include<cstring>
#include<string>
using namespace std;
int isvisit[500][500];
queue<int> where;
int row,col,firstx,firsty,counts;
char pathology[250][250];
int main()
{
     //freopen("input.txt","r",stdin);//调试时可以通过这个函数减少手动输入;
     while ( cin >> row >> col >> firsty >> firstx )
     {
      	if ( row == 0 || col == 0 || firsty == 0 || firstx == 0 ) break;
      	for ( int i = 1; i <= row; i++)
        {
             for ( int j = 1; j <= col; j++)  cin >> pathology[i][j];
        }
        counts = 0;
        memset( isvisit, 0, sizeof( isvisit ) );//初始化数组
        where.push( ( firsty - 1 ) * col + firstx - 1 );//把初始点加入队列中
       	isvisit[ firsty ][ firstx ] = 1;
        while ( !where.empty() )
        {
            int number = where.front();
            where.pop();//取出第一个元素
            int y = number / col + 1;
            int x = number % col + 1;
            if ( x == 1 ) counts++;
            if ( x == col ) counts++;//特别注意这里不能讲x==1 和 x == col用或连起来!如果行数是一的话要加两次,把两个条件连起来的话只是加了一次话wa;
            if ( y == 1 ) counts++;
            if ( y == row ) counts++;
            if ( x + 1 <= col && pathology[ y ][ x + 1 ] == '.') counts++;
            if ( x - 1 > 0 && pathology[ y ][ x - 1 ] == '.')  counts++;
            if ( y + 1 <= row && pathology[ y + 1 ][ x ] == '.') counts++;
            if ( y - 1 > 0 && pathology[ y - 1 ][ x ] == '.')  counts++;
            for ( int i = -1; i <= 1; i++ )
            {
                for ( int j = -1; j <= 1; j++ )
                {
                    int dx = x + i;
                    int dy = y + j;
                    if ( dx > 0 && dx <= col && dy > 0 && dy <= row && isvisit[ dy ][ dx ] == 0 && pathology[ dy ][ dx ] == 'X' )
                    {
                        where.push( ( dy - 1 ) * col + dx - 1 );
                        isvisit[ dy ][ dx ] = 1;
                    }
                }
            }
        }
        cout << counts << endl;
        while( !where.empty()) where.pop();
    }
}

 

 

 

 

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值