【POJ】poj 3009 (DFS)

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1
/*************************************************************************************************
**    这个题目的意思是以2为起点3为终点的最短路径,其中0是可以走的地方1是墙 隔一个0可以撞上去 **
**这是一道深度优先搜索的题目,用函数dfs()带两个参数,一个参数表示所在的位置,另外一个表示所 **
**走的步数通过搜索得出最短路径                                                                  **
**************************************************************************************************** */
#include <iostream>
#include<algorithm>
#include<cstdio>
#include<stdio.h>
#include<queue>
#include<cstring>
#include<string>
#include<cstring>
using namespace std;
int blocks[1005][1005];
int steps;
int row, col, start, goal, ans,tt,flag;
int run[4][2] = {{ 0, 1 }, {1, 0}, {-1, 0}, { 0, -1}};/**控制小球走的方向*/
inline bool inbound( int x, int y)
{
    return x >= 0 && x < col && y >= 0 && y < row;
}
void searchs( int where, int ans1)
{
    if ( ans1 > 10 ) return;
    if ( where == goal )
    {
        flag = 1;
        if ( steps > ans1 ) steps = ans1;
        return;
    }
    int x = where % col;
    int y = where / col;
    for ( int i = 0; i < 4; i++ )
    {
        int dx = x + run[i][0];
        int dy = y + run[i][1];
        if ( inbound(dx,dy) && ( blocks[dy][dx] == 0 || blocks[dy][dx] == 3 ))/**如果下一步在区域里面并且下一步可以走那么就搜索下一步*/
        {
            int temp = 1;
            while ( blocks[dy][dx] != 1 )
            {
                if ( blocks[dy][dx] == 3 )/**找到目标直接跳出*/
                {
                    flag = 1;
                    if ( steps > ans1 + 1 ) steps = ans1 + 1;
                    return;
                }
                dx += run[i][0];
                dy += run[i][1];
                if (!inbound(dx,dy))
                {
                    temp = 0; break;
                }
            }
            if ( temp == 0 ) continue;/**如果越界或者到了目的那么*/
            blocks[dy][dx] = 0;/** 将击打的砖块变为0*/
            //blocks[y][x] = 0;/**离开原来的位置要将原来的位置变为0*/
            searchs((dy - run[i][1]) * col + dx - run[i][0], ans1 + 1 );/**撞完之后搜索下一个状态*/
            //blocks[y][x] = 2;/**还原到原来的位置来*/
            blocks[dy][dx] = 1;/**将数据还原回来标记为砖块没有*/
        }
    }
}
int main()
{
    //freopen("input.txt","r",stdin);
    while ( cin >> col >> row )
    {
        if ( col == 0 ) break;
        for ( int i = 0; i < row; i++ )
        {
            for ( int j = 0; j < col; j++ )
            {
                cin >> blocks[i][j];
                if ( blocks [i][j] == 2 ) {start = i * col + j;blocks[i][j] = 0;}/**将起始点标记为可以走,不然的话如果相邻的话就不能走导致错误*/
                if ( blocks [i][j] == 3 ) goal = i * col + j;
            }
        }
        //memset(steps,0,sizeof(steps));
        flag = 0;steps = 11;
        searchs(start, 0);
        if ( flag == 0 || steps > 10 )
            cout << "-1" << endl;
        else
            cout << steps << endl;

    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值