POJ 3281 拆点网络流

Dining

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23833 Accepted: 10544

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

题目大意:有n头牛,f种草料,d种水,每种草料和每种水仅有一个单位,每头牛要吃一个单位草料和喝一个单位水。每头牛只对一部分草料和一部分水感兴趣。问你最多能完全满足多少头牛(草料和水均满意)?


分析:经典构图题:用拆点来限制流量,超级源点与每种食物相连,负载为1。每头牛拆点,负载为1(此处限制流量,一头牛只能转移一的流量)。每头牛拆点的出点与所有满意的食物相连,负载为1;每头牛拆点的入点再与所有满意的水相连,负载为1,每种水再与超级汇点相连,负载为1。最终看最大流跑出多少就是最大的,能够双双满足的牛的数量。

(另外有一种变体是食物和饮料数量不是1,则相应改变超级源点和超级汇点连接的边为对应数量即可。)

code:

#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
#include<map>
#include<set>
#include<cstring>
#include<queue>
#define mst(a,b) memset((a),(b),sizeof((a)))
#include<cmath>
#define rep(i,j,k) for(int i=j;i<k;++i)
#define pb push_back 
using namespace std;
typedef long long LL;
typedef vector<int,int> pii;
const int MAXN = 1005;
struct Edge{
	int to,cap,rev;
	Edge(){}
	Edge(int pt,int pc, int pr):to(pt),cap(pc),rev(pr){}
};
vector<Edge> G[MAXN];
int dep[MAXN];
int iter[MAXN];

void addEdge(int from, int to, int cap){
	G[from].pb(Edge(to,cap,G[to].size()));
	G[to].pb(Edge(from,0,G[from].size()-1));
}

bool bfs(int s, int t){
	mst(dep,-1);
	queue<int> q;
	q.push(s);
	dep[s] = 0;
	while(!q.empty()){
		int cur = q.front(); q.pop();
		rep(i,0,G[cur].size()){
			Edge &e = G[cur][i];
			if(dep[e.to] < 0 && e.cap > 0){
				dep[e.to] = dep[cur] + 1;
				q.push(e.to);
			}
		}
	}
	if(dep[t] < 0) return false;
	return true;
}

int dfs(int v, int t, int f){
	if(v == t) return f;
	int num = 0;
	for(int &i = iter[v]; i < G[v].size(); ++i){
		Edge &e = G[v][i]; // 这里要引用 
		if(dep[e.to] == dep[v] + 1 && e.cap > 0){
			int d = dfs(e.to,t,min(f,e.cap));
			if(d > 0){
				e.cap -= d;
				G[e.to][e.rev].cap += d;
				num += d;
				return d;
			}
		}
	}
	if(!num) dep[v] = -1;
	return 0;
}

int max_flow(int s, int t){
	int flow = 0;
	while(bfs(s,t)){
		int f;
		mst(iter,0);
		while((f = dfs(s,t,0x3f3f3f3f)) > 0){
			flow += f;
		}
	}
	return flow;
}

int main()
	{
		int s,t,N,F,D;
		while(scanf("%d%d%d",&N,&F,&D) != EOF){
			rep(i,0,MAXN) G[i].clear();
			s = 0; t = 2*N + F + D + 1;
			rep(i,1,F+1){
				addEdge(s,i,1);
			}
			rep(i,2*N+F+1,2*N+F+D+1){
				addEdge(i,t,1);
			}
			rep(i,F+1,N+F+1){
				addEdge(i,i+N,1);
			}
			int fi,di,x;
			rep(i,1,N+1){
				scanf("%d%d",&fi,&di);
				rep(j,0,fi){
					scanf("%d",&x);
					addEdge(x,i+F,1);
				}
				rep(j,0,di){
					scanf("%d",&x);
					addEdge(i+N+F,2*N+F+x,1);
				}
			}
			printf("%d\n",max_flow(s,t));
		}
		
	
		return 0;
	}


参考:https://blog.csdn.net/maxichu/article/details/45190521

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值