poj 2299 Ultra-QuickSort(树状数组+离散化)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 62342 Accepted: 23200

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


思路:其实就是求这些数每个数的逆序数的和。先将这些数据离散化,每一个数对应一个编号是连续的整数。要使这些数升序排序,就要求这些编号的逆序数之和。但树状数组每次查询都是查比它小的,不能做到逆序,所以我们可以将这些数据以降序来排。再用树状数组求的就是他们的逆序和。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=500105;
int n;
int tr[maxn];
struct node
{
    int x,p;
}q[maxn];
bool cmp(node a,node b)
{
    return a.x>b.x;
}
int lowbit(int i)
{
    return i&(-i);
}
void update(int x,int n)
{
    while(x<=n)
    {
        tr[x]+=1;
        x+=lowbit(x);
    }
}
int query(int n)
{
    int sum=0;
    while(n>0)
    {
        sum+=tr[n];
        n-=lowbit(n);
    }
    return sum;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(tr,0,sizeof(tr));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&q[i].x);
            q[i].p=i;
        }
        sort(q+1,q+1+n,cmp);
        long long res=0;
        for(int i=1;i<=n;i++)
        {
            res+=query(q[i].p);
            update(q[i].p,n);
        }
        printf("%lld\n",res);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值