Ultra-QuickSort

本文详细介绍了快速排序算法的一种优化实现——Ultra-QuickSort,包括其原理、步骤以及示例输入和输出。通过对算法的解析,读者可以理解如何通过这种排序算法有效地对数组进行排序。
摘要由CSDN通过智能技术生成
Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 62339 Accepted: 23198

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

/*
  归并排序是将两个(或两个以上)有序表合并成一个新的有序表,即把待排序序列分为 
*  若干个子序列,每个子序列是有序的,然后再把有序的子序列合并为整体有序序列 
*  归并排序是分治算法的一个典型的应用,而且是稳定的一种排序,这题利用归并排序 
*  的过程中,计算每个小区间的逆序数,进而得到大区间的逆序数。那么,问题就解决了。

归并排序是将数列a[l,h]分成两半a[l,mid]和a[mid+1,h]分别进行归并排序,然后再将这两半合并起来。
在合并的过程中(设l<=i<=mid,mid+1<=j<=h),当a[i]<=a[j]时,并不产生逆序数;当a[i]>a[j]时,在
前半部分中比a[i]大的数都比a[j]大,将a[j]放在a[i]前面的话,逆序数要加上mid+1-i。因此,可以在归并
排序中的合并过程中计算逆序数.

*/

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
#define N  1000002

long long  a[N],tmp[N];
long long ans;
//归并排序的合并部分 
void Merge(int l,int m,int r)
{
    int i = l;
    int j = m + 1;
    int k = l;
    while(i <= m && j <= r)
    {
        if(a[i] > a[j])
        {
            tmp[k++] = a[j++];
            ans += m - i + 1;
        }
        else
        {
            tmp[k++] = a[i++];
        }
    }
    while(i <= m) tmp[k++] = a[i++];
    while(j <= r) tmp[k++] = a[j++];
    for(int i=l;i<=r;i++)
        a[i] = tmp[i];
}
//l左端点,r右端点 
//归并排序 
void Merge_sort(int l,int r)
{
    if(l < r)
    {
        int m = (l + r) >> 1;
        Merge_sort(l,m);//将前半部分排序 
        Merge_sort(m+1,r);//将后半部分排序 
        Merge(l,m,r);//合并前后两个部分 
    }
}

int main()
{
    int n;
  
    while(scanf("%d",&n)&&n)
    {
       
        
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        ans = 0;
        //0左端点,n-1右端点 
        Merge_sort(0,n-1);
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值