hdu 1251 统计难题(字典树)

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 47718    Accepted Submission(s): 16883


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 

Author
Ignatius.L

题意:中文题。

思路:字典树。

这题坑的是没有给数据范围,用数组写的字典树的话范围要开大一点但不能开太大,开到400000就行了。当然为了避免这个坑点可以用指针来写字典树,但是要用C++,不然会爆内存。

注意一个细节就是如果查询的时候,发现它的下一个指向的地方并不存在,那么就直接返回0。

代码:

数组版

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int pos,root;
const int maxn=400000;
struct node
{
    int next[27];
    int cnt;
    node()
    {
        memset(next,0,sizeof(next));
        cnt=0;
    }
}q[maxn];
void in(int root,char s[])
{
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        if(q[root].next[x]==0)
        {
            q[root].next[x]=++pos;
        }
        root=q[root].next[x];
        q[root].cnt++;
    }
}
int query(int root,char s[])
{
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        root=q[root].next[x];
        if(root==0) return 0;
    }
    return q[root].cnt;
}
char s[15];
int main()
{
    while(gets(s)!=NULL)
    {
        if(strlen(s)!=0)
            in(root,s);
        else
        {
            while(gets(s)!=NULL)
            {
                printf("%d\n",query(root,s));
            }
        }
    }
    return 0;
}


指针版

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node
{
    node *next[26];
    int cnt;
    node()
    {
        memset(next,NULL,sizeof(next));
        cnt=0;
    }
};
void in(node* root,char s[])
{
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        if(root->next[x]==NULL)
        {
            root->next[x]=new node;
        }
        root=root->next[x];
        root->cnt++;
    }
}
int query(node *root,char s[])
{
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int x=s[i]-'a';
        if(root->next[x]==NULL) return 0;
        root=root->next[x];
    }
    return root->cnt;
}
int main()
{
    char s[15];
    node *root=new node;
    while(gets(s)!=NULL)
    {
        if(strlen(s)!=0)
        {
            in(root,s);
        }
        else
        {
            while(gets(s)!=NULL)
            {
                printf("%d\n",query(root,s));
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值