统计难题

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 
 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 
 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 
 

Sample Input

    
    
banana band bee absolute acm ba b band abc
 

Sample Output

    
    
2 3 1 0
 

字典树的模板,修改查找部分就行了

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
typedef struct Node
{
    Node *child[26];
    int n;
}Node;

void Insert(Node *root, char *str)//建树 
{
    int len = strlen (str);
    Node *ans = root;
    for (int i =0; i < len; i ++)
    {
        if (ans->child[str[i]-'a'] == NULL)
        {
            Node *NewNode = (Node*) malloc (sizeof (Node));
            NewNode->n = 1;
            for (int j = 0;j<26;j++)
             NewNode->child[j] = NULL;
            
            ans->child[str[i]-'a'] = NewNode;
            ans = NewNode;
        }
        else
        {
            ans = ans->child[str[i]-'a'];
            ans->n++;
        }
    }
}

int Search (Node *root,char c2[])//查找 
{
    Node *ans = root;
    int i,len=strlen(c2);
    for(i=0;i<len;i++)
     {   if(ans->child[c2[i]-'a']!=NULL)
            ans=ans->child[c2[i]-'a'];
         else return 0;
     }
    return ans->n;
}

void release(Node* root)//释放 
{
    int i;
    for(i=0;i<26;i++) 
       if(root->child[i]!=NULL) release(root->child[i]);
    delete root;
}

int main ()
{
    char c1[15],c2[15];   
    Node *root=(Node*)malloc(sizeof(Node));
    root->n=0;
    int i; 
    for (i = 0;i < 26;i++) 
       root->child[i] = NULL;
    
    while(gets(c1)&&c1[0]!='\0')
    {
      Insert(root,c1);
    }
     while(scanf("%s",&c2)!=EOF)
     {
        cout<<Search(root,c2)<<endl;
     }  
        release(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值