hdu 5045 Contest(状压DP)

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2143    Accepted Submission(s): 878


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. 

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. 

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. 

For each problem, each student has a certain probability that correct solve. If the i th student solve the j th problem, the probability of correct solve is P ij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. 

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the j th number in the i th line is P ij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
 
 
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
 
 
Case #1: 2.20000
 

Source
 

Recommend
hujie

题意:

有N个人要解决M道问题,两两之间解题数不能超过1道题。每个人都有解决一道题的概率,问最后期望能解决多少道题。

思路:

用DP[i][j],i表示解决了前i道问题,j当前解决问题的方案。

状态转移方程为

dp[i][status]=max(dp[i][status],dp[i-1][j]+d[k+1][i]),status=(j|(1<<k));

因为每个人之间解题数差异值不会超过1道题,所以当我们把所有人都排完了一种方案的时候,转移到下一个的时候应该所有人都清为0,然后再接着给他们分配题目。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
double d[11][1005];
double dp[1050][1050];
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%lf",&d[i][j]);
            }
        }
        int lim=(1<<n)-1;
        for(int i=0;i<=m;i++)
            for(int j=0;j<=lim;j++)
                dp[i][j]=-1.0;
        dp[0][0]=0;
        double ans=0;
        for(int i=1;i<=m;i++)
        {
            for(int j=0;j<=lim;j++)
            {
                if(dp[i-1][j]<0)
                    continue;
                for(int k=0;k<n;k++)
                {
                    if(!(j&(1<<k)))
                    {
                        int status=(j|(1<<k));
                        if(status==lim)
                            status=0;
                        dp[i][status]=max(dp[i][status],dp[i-1][j]+d[k+1][i]);
                    }
                }
            }
        }
        for(int i=0;i<=lim;i++)
            ans=max(ans,dp[m][i]);
        printf("Case #%d: %.5f\n",cas++,ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值