hdu5045 Contest 状压DP

1 篇文章 0 订阅

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1669    Accepted Submission(s): 669


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. 

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. 

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. 

For each problem, each student has a certain probability that correct solve. If the i th student solve the j th problem, the probability of correct solve is P ij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. 

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the j th number in the i th line is P ij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
  
  
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
  
  
Case #1: 2.20000
 


发现其实每个人的做题情况的要求,具有模2的性质,即不能比别人多做两道题,可以用二进制串进行状态压缩,使用一个长度为n的二进制串,每一位表示到当前为止那个人相对于上一轮是否做过题,如果他已经做过一次了,就暂时不再让他做,再让他做就会出现例如100201的情况,做2个题的人比做0个题的人要多做两个题,这里说的0,1,2都是相对于上一轮的,并不是绝对的数量


dp[i][t]为做到第i个题,人的做题状况为t时达到的最大概率和


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

double dp[1005][10005];
double p[15][1005];

int n, m, T, kase;

int main()
{
	cin >> T;
	kase = 0;
	while (T--) {
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= m; j++) {
				scanf("%lf", &p[i][j]);
			}
		}
		int lim = (1 << n) - 1;
		for (int i = 0; i <= m; i++) {
			for (int j = 0; j <= lim; j++) {
				dp[i][j] = -1.0;   //标记不不可能存在的状态为-1
			}
		}
		//for (int i = 0; i <= lim; i++) dp[0][i] = 0; //debug
		dp[0][0] = 0.0;
		for (int i = 1; i <= m; i++) {  //每个题
			for (int k = 0; k <= lim; k++) {  //到前一道题为止每个人的答题状况
				if (dp[i - 1][k] < 0.0) continue; //debug 前一种状态不存在,继续遍历查找
				for (int j = 0; j < n; j++) { //每个人
					int t = (1 << j);
					if (!(t & k)) {
						t = t | k;  //做这个题,更新做题状况
						if (t == lim) t = 0;  //每个人都做了一道题,重新开始轮
						dp[i][t] = max(dp[i][t], dp[i - 1][k] + p[j + 1][i]);
					}
				}
			}
		}
		double ans = 0.0;
		for (int i = 0; i <= lim; i++) {
			ans = max(ans, dp[m][i]);
		}
		printf("Case #%d: %.5f\n", ++kase, ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值