hdu 5014 Number Sequence(贪心)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3041    Accepted Submission(s): 1210
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
 
 
4 2 0 1 4 3
 

Sample Output
 
 
20 1 0 2 3 4
 

Source

题意:

给一个序列长度为N+1,序列的数字是从0到N互不相等。让你构造出一个序列使得他们对应下标的数异或和最大。

思路:

我们可以发现,对于一个2^n的数,2^n-1和它匹配是可以得到最大的。

进一步发现,2^n-2和2^n+1异或也是最大的,所以我们知道了匹配方法就是找到这样以2^n为中心对称的匹配是一个最优解。

所以我们不断重复这样的对称的规则来进行匹配就能得到最终答案。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
int a[maxn];
int b[maxn];
int c[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        ll ans=0;
        for(int i=0;i<=n;i++)
            scanf("%d",&a[i]);
        int k=(int)log2(n);
        int cheng=(int)pow(2,k);
        int pos=cheng;
        int p=1;
        while(pos<=n&&pos-p>=0)
        {
            c[pos-p]=pos;
            c[pos]=pos-p;
            ans+=((pos-p)^pos)*2;
            pos++;
            p+=2;
        }
        while(pos-p>=0)
        {
            pos-=p;
            p=1;
            k=(int)log2(pos);
            cheng=pos;
            pos=(int)pow(2,k);
            while(pos<=cheng&&pos-p>=0)
            {
                c[pos-p]=pos;
                c[pos]=pos-p;
                ans+=((pos-p)^pos)*2;
                pos++;
                p+=2;
            }
        }
        for(int i=0;i<=n;i++)
        {
            b[i]=c[a[i]];
        }
        printf("%lld\n",ans);
        for(int i=0;i<=n;i++)
        {
            if(i!=n)
                printf("%d ",b[i]);
            else
                printf("%d\n",b[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值