hdu 5014 Number Sequence (贪心)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 697    Accepted Submission(s): 332
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4

随意写一个二进制数x=100100,总能找到唯一的一个数与它异或得到111111;对于每个N位二进制数,每次总使它与一个数异或得到11...11(N个1)。即为最优解,且唯一。

#include"stdio.h"
#include"string.h"
#include"iostream"
#include"algorithm"
using namespace std;
#define N  100005
#define LL __int64
int a[N],b[N],p[N];
int fun(int x)  //求和X对应的数字
{
    int s=0,t[50],i=0;
    while(x)
    {
        t[i++]=x%2^1;     
        x/=2;
    }
    for(i--;i>=0;i--)
        s=(s<<1)+t[i];
    return s;
}
int main()
{
    int i,n;
    while(scanf("%d",&n)!=-1)
    {
        for(i=0;i<=n;i++)
        {
            scanf("%d",&a[i]);
            p[i]=-1;
        }
        for(i=n;i>=0;i--)
        {
            if(p[i]!=-1)
                continue;
            int t=fun(i);
            p[t]=i;
            p[i]=t;
        }
        LL s=0;
        for(i=0;i<=n;i++)
        {
            b[i]=p[a[i]];
            s+=a[i]^b[i];
        }
        printf("%I64d\n",s);
        for(i=0;i<n;i++)
            printf("%d ",b[i]);
        printf("%d\n",b[n]);
    }
    return 0;
}
因为如果a^b=c,可推出a^c=b,b^c=a;所以,想得到和X匹配的那个数字,直接让X与这个想得到数字异或也能得到。

#include"stdio.h"
#include"math.h"
#include"string.h"
#define LL __int64
#define N 100005
int a[N],p[N],b[N];
int fun(int x)
{
    int t=1;
    while(t<=x)
       t*=2;
    return x^(t-1);
}
int main()
{
    int i,n;
    while(scanf("%d",&n)!=-1)
    {
        for(i=0;i<=n;i++)
            scanf("%d",&a[i]);
        memset(p,-1,sizeof(p));
        for(i=n;i>=0;i--)
        {
            if(p[i]!=-1)
                continue;
            int t=fun(i);
            p[t]=i;
            p[i]=t;
        }
        LL s=0;
        for(i=0;i<=n;i++)
        {
            b[i]=p[a[i]];
            s+=a[i]^b[i];
        }
        printf("%I64d\n",s);
        for(i=0;i<n;i++)
            printf("%d ",b[i]);
        printf("%d\n",b[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值