OJ第三批——Problem S: E3 继承了,成员函数却不可访问

问题及代码:

Problem S: E3 继承了,成员函数却不可访问

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 447   Solved: 370
[ Submit][ Status][ Web Board]

Description

下面的程序中,派生类Derive继承自基类Base,main函数中,要通过Derive类的对象d,输出继承自Base及其自身的val数据成员的值。例如,输入的n为100,继承自Base及的val值是10,而自身的val的值为110。很遗憾,下面的程序中,在begin和end之间有两处语法错误,请修改并提交这部分代码。
#include <iostream>
using namespace std;
class Base
{
    private:
    int val;
public:
    Base():val(10){}
    int getV(){return val;}
};
//************* begin *****************
class Derive: Base //(1)
{
private:
    int val;
    int getV(){return val;}  //(2)
public:
    Derive():val(0){}
    void setV(int i)
    {
        val=Base::getV()+i;
    }
};
//************* end *****************
int main()
{
    int n;
    cin>>n;
    Derive d;
    d.setV(n);
    cout<<d.Base::getV()<<" "<<d.getV()<<endl;
    return 0;
}

Input

一个整数n,用于设置d.val的值

Output

两个整数,第一个是通过d对象的基类Base的成员函数getV返回的val值,固定为10,第二个是通过d对象的成员函数getV返回的val值,由函数的定义,为10加上输入的n值

Sample Input

100

Sample Output

10 110

HINT

 

#include <iostream>
using namespace std;
class Base
{
private:
    int val;
public:
    Base():val(10) {}
    int getV()
    {
        return val;
    }
};
//************* begin *****************
class Derive:public Base //(1)
{
private:
    int val;
public:
    int getV()
    {
        return val;   //(2)
    }
    Derive():val(0) {}
    void setV(int i)
    {
        val=Base::getV()+i;
    }
};
//************* end *****************
int main()
{
    int n;
    cin>>n;
    Derive d;
    d.setV(n);
    cout<<d.Base::getV()<<" "<<d.getV()<<endl;
    return 0;
}


 

运行结果:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值