OJ第六批——Problem F: A代码完善--简易二元运算

问题及代码:

 

Problem F: A代码完善--简易二元运算

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 236   Solved: 150
[ Submit][ Status][ Web Board]

Description

注:本题只需要提交填写部分的代码,请按照C++方式提交。

编写二元运算类,实现整数的加、减、乘和除四种运算。

#include <stdio.h>
#include <iostream>
using namespace std;
class FourArithOper
{
private:
    int operand1,operand2;
    char operator1;
public:
    FourArithOper(char op,int op1,int op2)
    {
        operand1=op1;
        operand2=op2;
        operator1=op;
    }
    void Algorithm()
    {
        cout<<operand1<<operator1<<operand2<<"=";
/**************************************************   
       请在该部分补充缺少的代码
**************************************************/
        cout<<endl;
    }
};
int  main()
{
    int op1,op2;
    char op;
    cin>>op>>op1>>op2; //操作符,运算数1,运算数2
    FourArithOper fa(op,op1,op2);
    fa.Algorithm();
    return 0;
}

Input

运算符,运算数1,运算数2

Output

按照运算符计算的结果(除法运算保留整数部分)

Sample Input

+ 10 20

Sample Output

10+20=30

HINT

#include <stdio.h> 
#include <iostream> 
using namespace std; 
class FourArithOper 
{ 
private: 
    int operand1,operand2; 
    char operator1; 
public: 
    FourArithOper(char op,int op1,int op2) 
    { 
        operand1=op1; 
        operand2=op2; 
        operator1=op; 
    } 
    void Algorithm() 
    { 
        cout<<operand1<<operator1<<operand2<<"="; 
        int n; 
        if(operator1=='+') 
            n=operand1+operand2; 
        if(operator1=='-') 
            n=operand1-operand2; 
        if(operator1=='*') 
            n=operand1*operand2; 
        if(operator1=='/') 
            n=operand1/operand2; 
        cout<<n<<endl; 
  
  
        cout<<endl; 
    } 
}; 
int  main() 
{ 
    int op1,op2; 
    char op; 
    cin>>op>>op1>>op2; //操作符,运算数1,运算数2 
    FourArithOper fa(op,op1,op2); 
    fa.Algorithm(); 
    return 0; 
} 


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值