10815 - Andy's First Dictionary

2 篇文章 0 订阅

 Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant idea. Fromhis bookshelf he would pick one of his favouritestory books, from which he would copy out allthe distinct words. By arranging the words inalphabetical order, he is done! Of course, it isa really time-consuming job, and this is where acomputer program is helpful.You are asked to write a program that listsall the different words in the input text. In thisproblem, a word is defined as a consecutive sequenceof alphabets, in upper and/or lower case.Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE.For example, words like “Apple”, “apple” or “APPLE”must be considered the same.

Input 

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Inputis terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. Thewords should all be in lower case, sorted in alphabetical order. You can be sure that he number ofdistinct words in the text does not exceed 5000.

Sample input

Adventures in Disneyland Two blondes were going to

 Disneyland when they came to a fork in theroad. The sign read: "Disneyland Left."So they went home.

Sample Output

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when

题目原址:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1756

题意:统计文本中的不同单词的数量,忽略大小写,对单词进行词典序排序。

所使用的库函数:

1. bool isalpha(char a)

   判断字符是否为字母,若是字母则返回真,否则为假。

2. char tolower(char a)

返回a的小写字母,对应的有char toupper(char b),返回b的大写字母。

词典序排序方法

比较简单的一个方法就是直接将单词存入set中,因为set本身就是词典序有序的。只要对set做一次遍历即可得到按词典序排列的单词。

另一个方法则是用sort函数

代码如下:

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;
set<string> dic;
int main(void) {
	string s, buffer;
	while (cin >> s) {
		for (int i = 0; i < s.length(); i++)
			if (isalpha(s[i]))
				s[i] = tolower(s[i]);
			else
				s[i] = ' ';
		stringstream sstream(s);
		while (sstream >> buffer)
			dic.insert(buffer);
	}
	for (set<string>::iterator it = dic.begin(); it != dic.end(); it++)
	{
		cout << *it << "\n";
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值