HDU 6038 Function

Function
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1317 Accepted Submission(s): 606

Problem Description
You are given a permutation a from 0 to n−1 and a permutation b from 0 to m−1.

Define that the domain of function f is the set of integers from 0 to n−1, and the range of it is the set of integers from 0 to m−1.

Please calculate the quantity of different functions f satisfying that f(i)=bf(ai) for each i from 0 to n−1.

Two functions are different if and only if there exists at least one integer from 0 to n−1 mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo 109+7.

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers n, m. (1≤n≤100000,1≤m≤100000)

The second line contains n numbers, ranged from 0 to n−1, the i-th number of which represents ai−1.

The third line contains m numbers, ranged from 0 to m−1, the i-th number of which represents bi−1.

It is guaranteed that ∑n≤106, ∑m≤106.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input

3 2
1 0 2
0 1
3 4
2 0 1
0 2 3 1

Sample Output

Case #1: 4
Case #2: 4

Source
2017 Multi-University Training Contest - Team 1

先找出a数列的所有的循环节然后在b中找f可以对应的值(同样是循环节),只有b
的某个循环节是a的某个循环节的因子时这两个循环节才能匹配,统计能匹配的个数,结果相乘。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=100009;
const ll mod=1e9+7;
int n,m,a[maxn],b[maxn];
int num1[maxn],num2[maxn];//num1[i]表示a数列第i个循环节的大小,num2[i]表示b数列长度为i的循环节的个数
int main()
{
    int cas=0;
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=0; i<n; i++) scanf("%d",&a[i]);
        for(int i=0; i<m; i++) scanf("%d",&b[i]);
        memset(num2,0,sizeof(num2));
        memset(num1,0,sizeof(num1));
        ///计算a的循环节
        int tot=0;
        for(int i=0; i<n; i++)
        {
            if(a[i]==-1) continue;
            int ii=i;
            tot++;
            //printf("%d\n",tot);
            while(a[ii]!=-1)
            {
                num1[tot]++;
                int t=ii;
                ii=a[ii];
                a[t]=-1;
            }
        }
        ///计算b的循环节
        for(int i=0; i<m; i++)
        {
            if(b[i]==-1) continue;
            int ii=i,len=0;
            while(b[ii]!=-1)
            {
                len++;
                int t=ii;
                ii=b[ii];
                b[t]=-1;
            }
            num2[len]++;
        }
        ll sum=1;
        for(int i=1; i<=tot; i++)
        {
            ll cnt=0;
            for(int j=1; j<=num1[i]; j++)
            {
                if(num1[i]%j==0)
                {
                    cnt+=num2[j]*j;
                    cnt%=mod;
                    //printf("%d %d\n",tot,cnt);
                }
            }
            sum*=cnt;
            sum%=mod;

        }
        printf("Case #%d: %lld\n",++cas,sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值