1033: A+B Problem (IV)

1033: A+B Problem (IV)

1.描述

Your task is to Calculate the sum of some integers.
输入
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

输出
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入
4 1 2 3 4
5 1 2 3 4 5
0
样例输出
10
15

翻译

题目描述
您的任务是计算某些整数的总和。

输入
输入包含多个测试用例。每个测试用例都包含一个整数 N,然后 N 个整数在同一行中跟随。以 0 用例终止输入,并且不处理此测试用例。

输出
对于每组输入整数,应在一行中输出它们的总和,并在输入中每行输出一行。

样例输入
4 1 2 3 4
5 1 2 3 4 5
0
样例输出
10
15

2.代码

#include<stdio.h>
int main()
{
    int n,m,i,j;
    while( scanf("%d",&n),n!=0)
    {
        m=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&j);
            m+=j;
        }
        printf("%d\n",m);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

汤米先生

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值