poj 2481 Cows

poj 2481

解题收获

对于一些区间型问题,可以对一端进行排序,使得按序天然满足条件,然后对另外一个端点用树状数组进行计算或统计。

Description

Farmer John’s cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John’s N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
using namespace std;

struct Node{
    int first,second,pos;
};
const int n=100001;
struct Node nodes[100001];
int ans[100001],tr[100002];
bool cmp(struct Node n1,struct Node n2)
{
    return n1.first<n2.first || n1.first==n2.first && n1.second > n2.second;
}
int lowbit(int x)
{
    return x & -x;
}
void update(int x, int c)  // 位置x加c
{
    for (int i = x; i <= n; i += lowbit(i)) tr[i] += c;
}
int query(int x)  // 返回前x个数的和
{
    int res = 0;
    for (int i = x; i; i -= lowbit(i)) res += tr[i];
    return res;
}
int main()
{
    int N;
    while(scanf("%d",&N),N){
        memset(tr,0,sizeof tr);
        for(int i=1;i<=N;i++){
            scanf("%d%d",&nodes[i].first,&nodes[i].second);
            nodes[i].first++; nodes[i].second++;
            nodes[i].pos=i;
        }
        sort(nodes+1,nodes+1+N,cmp);
        for(int i=1;i<=N;i++){
            update(nodes[i].second,1);
            ans[nodes[i].pos]=i-query(nodes[i].second-1)-1;
            for(int j=i-1;j>=1;j--)
                if(nodes[i].first==nodes[j].first&&nodes[i].second==nodes[j].second)
                    ans[nodes[i].pos]--;
                else
                    break;
        }
        bool flag=false;
        for(int i=1;i<=N;i++){
            printf("%d ",ans[i]);
        }
        printf("\n");
    }
    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值