poj 2481 Cows (n 个区间,每个区间被其他多少个区间完全覆盖)

Cows

 

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j. 

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i. 

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

 

题意:给定n个区间,问每个区间被其他多少个区间完全覆盖。完全覆盖的条件是,L1 <= L2 && R2 <= R1,且两个区间不同

思路:和线段树求逆序对比较类似。先对E从大到小排序,然后根据E建树维护S的个数,for中更新与查询,这样就保证了E的大小,剩下就只需要算小于当前位置的 S 的个数就可以,。

!!!对于两个相同的区间,直接复制前一个就可以了

AC代码:

#include<cstring>
#include<map>
#include<algorithm>
#include<cstdio>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 1e5 + 10;

struct xx{
    int x,y;
    int id;
}a[maxn];

bool cmp(xx A,xx B){
    if(A.y != B.y) return A.y > B.y;
    return A.x < B.x;
}

int sum[maxn << 2];

void update(int l,int r,int pos,int i){
    if(l == r){
        ++ sum[i];
        return ;
    }
    int mid = (l + r) >> 1;
    if(pos <= mid) update(l,mid,pos,i << 1);
    if(pos > mid) update(mid + 1,r,pos,i << 1 | 1);
    sum[i] = sum[i << 1] + sum[i << 1 | 1];
}

int query(int l,int r,int ql,int qr,int i){
    if(ql <= l && r <= qr){
        return sum[i];
    }
    int mid = (l + r) >> 1;
    int ans = 0;
    if(ql <= mid) ans += query(l,mid,ql,qr,i << 1);
    if(qr > mid) ans += query(mid + 1,r,ql,qr,i << 1 | 1);
    return ans;
}
int ans[maxn];

int main() {
    int n;
    while(~scanf("%d",&n)){
        if(!n) break;
        int maxx = 0;
        for(int i = 1;i <= n;++ i){
            scanf("%d%d",&a[i].x,&a[i].y);
            ++ a[i].x; ++ a[i].y;
            a[i].id = i;
            maxx = max(maxx,a[i].x);
        }
        sort(a + 1,a + 1 + n,cmp);
        clr(ans,0);
        clr(sum,0);
        for(int i = 1;i <= n;++ i){
            int x = query(1,maxx,1,a[i].x,1);
            update(1,maxx,a[i].x,1);
            ans[a[i].id] = x;
            if(a[i].y == a[i - 1].y && a[i].x == a[i - 1].x)
                ans[a[i].id] = ans[a[i - 1].id];
        }
        for(int i = 1;i <= n;++ i)
            printf("%d\n",ans[i]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值