杭电oj 1050 Moving Tables的解法

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5541 Accepted Submission(s): 1552

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output
The output should contain the minimum time in minutes to complete the moving, one per line.

**Sample Input**
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 


**Sample Output**
10
20
30

解法一:贪心算法
建立每个移动楼层的节点,以移动到的较大的楼层(对输入的数据进行调整,如80to20,改为20to80)为依据对节点数组进行升序排序,每一次都从头开始遍历,如果在这一次遍历能够遇到能并行移动的节点,那么节点标志置位,表示这些节点都已经同时移动过了,记录这样的遍历需要几次,也就是不可以同时遍历的次数即可。

#include<iostream>
#include<algorithm>
#define maxi 200
using namespace std;
typedef struct node{
    int left;
    int right;
    bool jud;
}mynodes;
mynodes nodes[maxi];
bool cmp(node a,node b){
    return a.right<b.right;
}
int main(){
    int number;
    int times;
    int i;
    int temp;
    cin>>number;
    while(number--){
        cin>>times;
    for(i=0;i<times;i++)
        {
        cin>>nodes[i].left>>nodes[i].right;
            nodes[i].jud=false;
            if(nodes[i].left>nodes[i].right)
            {
            temp=nodes[i].left;
            nodes[i].left=nodes[i].right;
            nodes[i].right=temp;
            }
            if(nodes[i].left%2==0)
                nodes[i].left--;
            if(nodes[i].right%2==1)
                nodes[i].right++;
        }
        sort(nodes,nodes+times,cmp);
    /////////////////////////////
         int result=-1;
        bool completion=false;
        while(!completion){
            result++;
             int endtime=0;
             completion=true;
            for(i=0;i<times;i++)
            {
                if(!nodes[i].jud&&endtime<nodes[i].left)
                {
                    endtime=nodes[i].right;
                    nodes[i].jud=true;
                    completion=false;
                }
            }
   //         cout<<"Endtime"<<endtime<<endl;
    }
    cout<<result*10<<endl;
    }
    return 0;
}

这个思路没有问题,但是几次都没有AC,固特意去网上寻找类似的答案,发现同样这样的思路也有没有AC的,不过庆幸的是遇到了更加简洁明了的AC方式(转换为点覆盖问题),某点被覆盖的次数最多的次数就是需要多少次移动的次数:

#include<iostream>
#include<string.h>
#define maxi 200
using namespace std;
int p[200];

int main(){
    int number;
    int tables;
    int b,e;
    cin>>number;
    while(number--){
        cin>>tables;
        memset(p,0,sizeof(p));
        int max=0;
        while(tables--)
        {
            cin>>b>>e;
            if(b>e)//利用位处理来交换数据
            {
                b^=e;
                e^=b;
                b^=e;
            }
            b=(b+1)/2;
            e=(e+1)/2;
            for(int i=b;i<=e;i++)
            {
                if(++p[i]>max)
                    max=p[i];
            }
        }
        cout<<max*10<<endl;
    }
    return 0;
}

这部分代码已经ac,读者可以放心使用。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值