杭电oj上的moving tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6414 Accepted Submission(s): 1766
 
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 
Sample Input
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 
 
Sample Output
10
20
30
 
 
Source
Asia 2001, Taejon (South Korea)

谈谈这道题的思路吧,原本想学习一下的,后面发现点覆盖方式最简单,就用点覆盖了,从第一幅图中可以看到有400间房间,但是老板考虑的是用走廊,所以只要考虑200段的走廊就好了,然后把每段走廊用一点标记,每重复一次,就用加一次,因为如果没重复的话,可以同时进行,所以只需考虑重复次数最多的即可,共用走廊和房间的话,也是要多加一次的。

#include<stdio.h>

#include<string.h>
int main()
{
int t=1,b,c,i,s,m,n;
char a[201];
scanf("%d",&n);
while(n--)
{
        memset(a,0,sizeof(a));//用零覆盖数组
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d%d",&b,&c);
if(b>c)//如果输入的房间号是由大到小的话,先排序一下
{
s=b;
b=c;
c=s;
}
for(s=(b+1)/2;s<=(c+1)/2;s++)
{
a[s]++;
}
}
for(i=1;i<201;i++)//检测每一个房间被覆盖的次数,最多的就是需要移动最多次
{
if(a[i]>t) t=a[i];
}
printf("%d\n",10*t);//每次需要10分钟
t=1;
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值