POJ 3746 Cyclic Nacklace

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10080    Accepted Submission(s): 4313


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3 aaa abca abcde
 

Sample Output
  
  
0 2 5

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3746

题意:输入一个字符串str问最少需要在字符串的末尾加上几个字符可以使该字符串存在一个循环节。

解题思路:KMP,就是查找字符串的循环节,由循环节可以知道,末尾字符作为循环节的重点是循环节长度最小的,当然,当该字符串本身存在循环节的时候需要加的字符串个数问0,也就是循环节的长度cir=(l-next[l]),当cir!=l,且cir可以被l整除时,那么该字符串本身就是一个完美的字符串不需要再加字符,当不存在循环节的时候,需要加的最小字符数为cir-(l%cir),所以代码如下。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXL = 1e5 + 10; //定义最大的字符串的长度 
char str[MAXL];
int fail[MAXL];
void get_fail(int l) //得到失配数组 
{
	fail[0]=0;
	fail[1]=0;
	for(int i=1;i<l;i++)
	{
		int j=fail[i];
		while(j && str[i]!=str[j]) j=fail[j];
		fail[i+1]=str[i]==str[j]?j+1:0;
	}
}
void solve()
{
	int ans;
	int l=strlen(str); //输入字符串的长度 
	get_fail(l); //得到失配数组 
	int cir=l-fail[l]; 
	if(cir!=l && l%cir==0) ans=0; //本身就是完美字符串 
	else ans=cir-(fail[l]%cir); //计算最少需要加的字符 
	printf("%d\n",ans);
}
int main(void)
{
	int T; //测试组数 
	scanf("%d",&T);
	getchar();
	while(T--)
	{
		scanf("%s",str); //输入字符串 
		solve(); //处理函数 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值