POJ 3974 Palindrome

Palindrome
Time Limit: 15000MS Memory Limit: 65536K
Total Submissions: 10048 Accepted: 3823

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?" 

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not. 

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!". 

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity). 

Output

For each test case in the input print the test case number and the length of the largest palindrome. 

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6

题目链接:http://poj.org/problem?id=3974

题意:给定字符串,输出最长的回文子串的长度。

解题思路:manacher算法。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN = 1e6 + 10;
char str[MAXN];
char ss[MAXN*2];
int P[MAXN*2];
void init_ss() 
{
	ss[0]='#'; //首位插入无关字符 
	int i,j;
	for(i=0,j=1;str[i]!='\0';i++) //相邻字符之间插入无关字符 
	{
		ss[j++]=str[i];
		ss[j++]='#';
	}
	ss[j]='\0'; //末尾插入无关字符 
}
void get_p()
{
	P[0]=1;
	int pos=0; 
	int max_right=0; //最右边的位置 
	for(int i=1;ss[i]!='\0';i++) //manacher算法 
	{
		if(max_right>i) P[i]=min(P[pos*2-i],max_right-i);
		else P[i]=1;
		for(;i-P[i]>=0&&ss[i-P[i]]==ss[i+P[i]];P[i]++)
		if(i+P[i]>max_right)
		{
			max_right=i+P[i];
			pos=i;
		}
	}
}
void solve()
{
	int ans=0;
	init_ss(); //初始化字符串(插入无关字符) 
	get_p(); //得到P数组 
	for(int i=0;ss[i]!='\0';i++) //获取最大回文长度 
	{
		ans=max(ans,P[i]-1);
	}
	printf("%d\n",ans);
}
int main(void)
{
	int kase=0; //测试组数 
	scanf("%s",str); //输入的字符串 
	while(strcmp(str,"END")) //输入结束标志 
	{
		printf("Case %d: ",++kase);
		solve(); //处理函数 
		scanf("%s",str);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值