HDU 3336 Count the string

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11036    Accepted Submission(s): 5144

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 
Sample Input
  
  
1 4 abab
 
Sample Output
  
  
6


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3336

题意:输入一个字符串str,统计字符串的每一个前缀是作为子串在原串中出现的次数,对10007取余。

解题思路:最近一直在刷KMP的题,最开始看到这个题目的时候想着算出失配数组,再将每一个前缀字符串去比较,可想而知TLE,所以不得已看了一位大佬的结题报告,就发现一个公式dp[i]=dp[next[i]]+1,即统计字符串str[0...i]中以str[i]结尾的字符串的个数,自己动手推一下很容易得到的,前提就是要有大佬的指示,哈哈。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN = 2e5 + 10; //最大的字符串长度 
const int MOD = 10007; //取余常数 
char str[MAXN]; //输入的字符串 
int fail[MAXN]; //失配数组 
int n; //字符串的长度 
void get_fail() //获得失配数组 
{
	fail[0]=0;
	fail[1]=0;
	for(int i=1;i<n;i++) 
	{
		int j=fail[i];
		while(j && str[i]!=str[j]) j=fail[j];
		fail[i+1]=str[i]==str[j]?j+1:0;
	}
}
void solve()
{
	get_fail();
	int ans=0; //答案 
	int dp[MAXN]; //记录每一个字符的状态 
	memset(dp,0,sizeof(dp)); 
	for(int i=1;i<=n;i++)
	{
		dp[i]=dp[fail[i]]+1;
		ans=(ans%MOD+dp[i]%MOD)%MOD;
	}
	printf("%d\n",ans); 
}
int main(void)
{
	int T; //测试组数 
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n); //输入字符串的长度 
		getchar();
		scanf("%s",str);
		solve(); //处理函数 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值