poj 1611 The Suspects 并查集

The Suspects,题目链接,点这里。

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 31216 Accepted: 15162
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
Source

Asia Kaohsiung 2003

中文翻译

Description

严重急性呼吸系统综合症( SARS), 一种原因不明的非典型性肺炎,从20033月中旬开始被认为是全球威胁。为了减少传播给别人的机会, 最好的策略是隔离可能的患者。 
在Not-Spreading-Your-Sickness大学( NSYSU), 有许多学生团体。同一组的学生经常彼此相通,一个学生可以同时加入几个小组。为了防止非典的传播,NSYSU收集了所有学生团体的成员名单。他们的标准操作程序(SOP)如下: 
一旦一组中有一个可能的患者, 组内的所有成员就都是可能的患者。 
然而,他们发现当一个学生被确认为可能的患者后不容易识别所有可能的患者。你的工作是编写一个程序, 发现所有可能的患者。 

Input

输入文件包含多组数据。 
对于每组测试数据: 
第一行为两个整数n和m, 其中n是学生的数量, m是团体的数量。0 < n <= 300000 <= m <= 500。 
每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。 
紧随其后的是团体的成员列表,每组一行。 
每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。 
n = m = 0表示输入结束,不需要处理。

Output

对于每组测试数据, 输出一行可能的患者。 

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题意已经很清楚了,那么现在就是将代码实现的过程了。
一开始就是感觉并查集,直接最后找一遍父节点比较0的父节点就可以了。

#include<string>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
const int maxn = 30005;
int father[maxn];//存储
//初始化;
void init(int n)
{
    for(int i=0;i<=n;i++)
        father[i]=i;
}
//找爹函数;路径压缩;
int get(int t)
{
    if(t!=father[t])
        father[t]=get(father[t]);
    return father[t];
}
//合并函数;
void  Merge(int a,int b)
{
    int t1=get(a),t2=get(b);
    if(t1!=t2)
    {
        if(father[t1]<father[t2])//归并小的父节点给大的;
            father[t2]=t1;
        else
            father[t1]=t2;
    }
    return ;
}

int main()
{
    int n,m,t;
    int c,b,a,f;
    while(~scanf("%d%d",&n,&m),n+m)
    {
        init(n);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&t,&f);
            for(int i=1;i<t;i++)
            {
                scanf("%d",&a);
                Merge(f,a);//直接合并;
            }
        }
        int coun=1;
        b=father[0];//0 的父节点;

        //遍历一遍,找父节点,比较;
        for(int i=1;i<=n;i++)
            if(get(i)==b)
                coun++;
        printf("%d\n",coun);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值