poj 3468 A Simple Problem with Integers 线段树,区间更新.

A Simple Problem with Integers,题目链接 ,click here

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly–2007.11.25, Yang Yi

一道很经典的线段树区间更新,上浮还有下浮,套模板就能过的.




#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define lson l,m,rt<<1       //左儿子;
#define rson m+1,r,rt<<1|1   //右儿子;
#define root 1,n,1           //建树的时候简便用的;
#define ll long long         //long long ;
const int N    =  100005;
ll sum[N<<2];   //建树数组;
ll add[N<<2];   //延迟标记,更新;

//上浮;
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
//下沉;
void pushdown(int rt,int m)
{
    if(add[rt])
    {
        add[rt<<1]  +=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]  +=add[rt]*(m-(m>>1));
        sum[rt<<1|1]+=add[rt]*(m>>1);
        add[rt]=0;
    }
}

//建树;
void build(int l,int r,int rt)
{
    add[rt]=0;
    if(l==r)
    {
        scanf("%I64d",&sum[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);//注意上浮;
}

//更新;
void update(int L,int R,int c,int l,int r,int rt)
{
    if(L<=l&&r<=R)
    {
        add[rt]+=c;
        sum[rt]+=(ll)c*(r-l+1);
        return;
    }
    pushdown(rt,r-l+1);//注意下沉;
    int m=(l+r)>>1;
//    if(L<=m) update(L,R,c,lson);
//    if(R>m)  update(L,R,c,rson);
//这里的判断用上边的还是用下边的都可以;
    if(R<=m)
            update(L,R,c,lson);
    else if(L>m)
        update(L,R,c,rson);
    else
    {
        update( L ,m,c,lson);
        update(m+1,R,c,rson);
    }
    pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
        return sum[rt];
    pushdown(rt,r-l+1);
    int m=(l+r)>>1;
    ll ans=0;
    if(L<=m) ans+=query(L,R,lson);
    if(R>m)  ans+=query(L,R,rson);
    return ans;
}
int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    build(root);
    char op[5];
    while(q--)
    {
        int a,b,c;
        scanf("%s",op);
        if(op[0]=='Q')
        {
            scanf("%d%d",&a,&b);
            printf("%I64d\n",query(a,b,root));
        }
        else
        {
            scanf("%d%d%d",&a,&b,&c);
            update(a,b,c,root);
        }
    }
    return 0;
}

很简单的一道题,硬是让我写了一下午,写了两遍,对自己的智商感到深深的忧桑~!!
一个位运算”<<”让我写成”>>”,改了好久…好坑!!一直RE.QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值