PAT basic-level 1065 单身狗 笔记

1065. 单身狗(25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
“单身狗”是中文对于单身人士的一种爱称。本题请你从上万人的大型派对中找出落单的客人,以便给予特殊关爱。

输入格式:

输入第一行给出一个正整数N(<=50000),是已知夫妻/伴侣的对数;随后N行,每行给出一对夫妻/伴侣——为方便起见,每人对应一个ID号,为5位数字(从00000到99999),ID间以空格分隔;之后给出一个正整数M(<=10000),为参加派对的总人数;随后一行给出这M位客人的ID,以空格分隔。题目保证无人重婚或脚踩两条船。

输出格式:

首先第一行输出落单客人的总人数;随后第二行按ID递增顺序列出落单的客人。ID间用1个空格分隔,行的首尾不得有多余空格。

输入样例:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
输出样例:
5
10000 23333 44444 55555 88888


简单题,不多说

#include <iostream>
#include <vector>
#include <iterator>
#include <algorithm>
using namespace std;

int main() {
  int n; 
  cin >> n;
  vector<int> couple(100000, -1);
  int x, y;
  for (int i = 0; i < n; i++){
    cin >> x >> y;
    couple[x] = y;
    couple[y] = x;
  }
  int m;
  cin >> m;
  vector<int> fid(m+1, -2);
  for (int i = 1; i <= m; ++i)
    cin >> fid[i];
  vector<int> single;
  for (int i = 1; i <= m; ++i){
    if (couple[fid[i]] == -1)
      single.push_back(fid[i]);
    else {
      vector<int>::iterator it = find(fid.begin(), fid.end(), couple[fid[i]]);
      if (it == fid.end())
        single.push_back(fid[i]);
    }
  }
  sort(single.begin(), single.end());
  cout << single.size() << endl;
  /*if (single.size() == 0){
    cout << endl;
    return 0;
  }*/
  for (unsigned i = 0; i < single.size(); ++i){
    cout.width(5);
    cout.fill('0');
    cout << single[i];
    if (i != single.size() - 1)
      cout << ' ';
  }

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值