hdu 2844 Coins (多重背包问题)

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8

4

题目大意:

现在你有一些面值不等的硬币,每个硬币都有各自的数量,现在想要你用这些硬币凑成不高于m的金额,问

你能够凑多少种金额。

题目分析: 这是一道多重背包问题,因为每件物品都有各自的数量且数量已知,多重背包其实就是完全背

包和01背包的结合,所以这个代码也相当于01背包和完全背包的模板了,而且这个多重背包用到了二进制的

优化,这个优化说实话,忘了啥意思了,好像就是把物品的数量按章8421码进行分配,可以节省空间的感觉。

还好不长,可以背下来直接当模板。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100005;
int dp[maxn];
int c[maxn],w[maxn];
int v;
void zerobeg(int cost,int weight){
	for(int i=v;i>=cost;i--){
		dp[i]=max(dp[i],dp[i-cost]+weight);
	}
} 
void completebeg(int cost,int weight){
	for(int i=cost;i<=v;i++)
	   dp[i]=max(dp[i],dp[i-cost]+weight);
}
void multiplybeg(int cost,int weight,int cnt){
	if(cnt*cost >= v){
		completebeg(cost,weight);
		return ;
	}
	else{
		int k=1;
		while(k<=cnt){
			zerobeg(k*cost,k*weight);
			cnt=cnt-k;
			k=2*k;
		}
		zerobeg(cnt*cost,cnt*weight);
	}
}
int main(){
	int n,m;
	while((scanf("%d%d",&n,&v))!=EOF){
		memset(dp,0,sizeof(dp));
		memset(c,0,sizeof(c));
		memset(w,0,sizeof(w));
		if(n==0&&v==0)
		   break;
		for(int i=0;i<n;i++)
			scanf("%d",&c[i]);
		for(int i=0;i<n;i++)
		    scanf("%d",&w[i]);
		for(int i=0;i<n;i++)
			multiplybeg(c[i],c[i],w[i]);
        int sum=0;
        for(int i=1;i<=v;i++){
        	if(dp[i] == i)
        	  sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值