IMMEDIATE DECODABILITY POJ - 1056 (字典树)


An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000 

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 
Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
 



题意: 给你一个由很多01字符串组成的集合,问你集合中有没有一个字符串是其他另外一个或多个字符串的前缀.


思路: 给节点增加个ending 标记, 记录每一个串得端点。 边插入边判断就好了


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const int N = 1e5;
struct Trie{
	bool ending;
	int child[10];
	Trie(){
		ending = 0;
		memset(child,0,sizeof(child));
	}
}trie[N];
int trieN;

void init(){
	memset(trie[0].child,0,sizeof(trie[0].child));
	trieN = 0;
}

bool Insert(const string& str){
	bool flag = 1;
	int cur = 0;
	for(int i = 0;str[i];i++){
		int d = str[i] - '0';
		if (trie[cur].child[d] == 0){
			trie[++trieN] = Trie();
			trie[cur].child[d] = trieN;
			flag = 0;
		}
		cur = trie[cur].child[d];
		if (trie[cur].ending) return true;
	}
	trie[cur].ending = 1;
	if (flag) return true;
	return false;
}

int main(){
	ios::sync_with_stdio(false);
	int t = 0;
	init();
	bool flag = 0;
	string str;
	while(cin >> str) {
		if (str[0] != '9') {
    		bool ret = Insert(str);
    		if (flag == 0) flag = ret;
    	} else {
    	    if (flag) cout << "Set " << ++t << " is not immediately decodable\n";
    	    else cout << "Set " << ++t << " is immediately decodable\n";
    	    
    	    init();flag = 0;
    	}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值