【hdu】 Immediate Decodability (字典树)

Immediate Decodability

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3
Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
   
   
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
   
   
Set 1 is immediately decodable Set 2 is not immediately decodable
 STL: 
1056Accepted680K0MSG++781B2012-08-07 09:51:36

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
    int i,T=0;
    char s[15];
    bool flag;
    while(scanf("%s",s)!=EOF)
    {    int n=0;
         vector<string> v;
         flag=true;
         T++;
         while(s[0]!='9')
         {
            v.push_back(string(s));
            scanf("%s",s);
            n++;
         }
         sort(v.begin(),v.end());
         for(int j=0;j<n-1;j++)
         {
                 if(v[j+1].find(v[j])==0 ){flag=false;break;}
         }
         if(flag==false)  
              printf("Set %d is not immediately decodable\n",T); 
         else printf("Set %d is immediately decodable\n",T);
    }
    return 0;
}
            

静态字典树:
1056Accepted660K0MSG++1230B 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
       int next[2];
       int id;
}head[1000];
char s[15];
bool flag;
int cnt;
void build(char *a,int idx,int id)
{
     int len=strlen(a),i,k;
     for(i=0;i<len;i++)
     {
        k=a[i]-'0';
        if(head[idx].next[k]==0) 
           head[idx].next[k]=cnt++;
        if((head[idx].id)&&(head[idx].id!=id))
           flag=false;
        idx=head[idx].next[k];
     }
     head[idx].id=id;
}
                                
int main()
{
        int i,T=0;;
        while(scanf("%s",s)!=EOF)
        {
                flag=true;
                T++;
                cnt=1;
                memset(head,0,sizeof(head));
                i=1;
                while(s[0]!='9')
                {
                    if(flag) build(s,0,i);
                    scanf("%s",s);
                    i++;
                }
                if(flag==false)
                   printf("Set %d is not immediately decodable\n",T);
                else printf("Set %d is immediately decodable\n",T);
        }
        return 0;
}
                
                
                



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值