C/C++ 循环练习:判断素数
题目描述
输入一个整数,若是素数,输出“YES”,否则输出“NO”
若是合数,输出“YES”,否则输出“NO”
输入
输入只有一行,包括1个整数。
输出
输出只有两行。
样例输入
5
样例输出
YES
NO
这道题比较简单,穷举出来再判断就可以了。接下来上代码。
先上C++风格的代码:
#include<iostream>
using namespace std;
int n;
bool s;
int main()
{
cin>>n;
if(n%2==0&&n!=2)
{
cout<<"NO"<<endl<<"YES";
return 0;
}
if(n==2)
{
cout<<"YES"<<endl<<"NO";
return 0;
}
if(n==1)
{
cout<<"NO"<<endl<<"NO";
return 0;
}
for(int i=3;i<=n/2;i++)
{
if(n%i==0) s=true;
}
if(s==false)
cout<<"YES"<<endl<<"NO";
else {
cout<<"NO"<<endl<<"YES";
}
return 0;
}
C风格的代码:
#include<stdio.h>
int n,s;
int main()
{
scanf("%d",&n);
if(n%2==0&&n!=2)
{
printf("NO\nYES");
return 0;
}
if(n==2)
{
printf("YES\nNO");
return 0;
}
if(n==1)
{
printf("NO\nNO");
return 0;
}
for(int i=3;i<=n/2;i++)
{
if(n%i==0) s=1;
}
if(s==0)
printf("YES\nNO");
else {
printf("NO\nYES");
}
return 0;
}
最后,各位小伙伴不喜勿喷,喜欢的话点点赞哦~~