POJ 2251 Dungeon Master (搜索 -- BFS)

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28101 Accepted: 10975

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source

Ulm Local 1997


题目大意:你被困在了一个三维迷宫,你现在要设法逃出去,问你能不能逃出去?如果能,则输出能逃出去的需要的最少时间是多少(每分钟移动一格)

解题思路:这题是很基础的搜索题,唯一的特点是这是一道三维的搜索题,似乎用DFS也能做,但是不知道我用DFS写的代码本地测试都过不了,不知道是有bug还是这题不能用DFS...... 看网上各位的题解都是用BFS做,于是我最后决定写一波BFS。

解题反思:虽然这道题BFS真的很基础,但是调试还是折腾了我好一阵——原因是把三维数组x,y,z搞反了好几次,于是第一组测试数据一直得到"Trapped"的错误结果... 这种低级错误真不应该犯,牢记牢记!!!



#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

char maze[35][35][35];
int vis[35][35][35];
int dx[]= {-1,0,1,0,0,0};
int dy[]= {0,-1,0,1,0,0};
int dz[]= {0,0,0,0,1,-1};
int l,r,c;
int sx,sy,sz;
int cnt;

struct Status
{
    int x;
    int y;
    int z;
    int step;
};

queue <Status> q;

bool inMap(int x,int y,int z)
{
    if(x>=0 && x<r && y>=0 && y<c && z>=0 && z<l)
        return true;
    return false;
}

void bfs()
{
    Status now,next;
    now.x=sx;
    now.y=sy;
    now.z=sz;
    now.step=0;
    cnt=INF;
    vis[sx][sy][sz]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        next.x=now.x;
        next.y=now.y;
        next.z=now.z;
        if(maze[now.x][now.y][now.z]=='E')
        {
            cnt=min(now.step,cnt);
            while(!q.empty())
                q.pop();
        }
        for(int i=0; i<6; i++)
        {
            next.x=now.x+dx[i];
            next.y=now.y+dy[i];
            next.z=now.z+dz[i];
            if(inMap(next.x,next.y,next.z) && !vis[next.x][next.y][next.z] && maze[next.x][next.y][next.z]!='#')
            {
                vis[next.x][next.y][next.z]=1;
                next.step=now.step+1;
                q.push(next);
            }
        }
    }
    if(cnt==INF)
        cout << "Trapped!" << endl;
    else
        cout << "Escaped in " << cnt << " minute(s)." << endl;
}

int main()
{
    while(cin >> l >> r >> c)
    {
        memset(vis,0,sizeof(vis));
        if(l==0 && r==0 && c==0)
            break;
        for(int k=0; k<l; k++)
        {
            for(int i=0; i<r; i++)
            {
                for(int j=0; j<c; j++)
                    cin >> maze[i][j][k];
            }
        }
        for(int k=0; k<l; k++)
        {
            for(int i=0; i<r; i++)
            {
                for(int j=0; j<c; j++)
                {
                    if(maze[i][j][k]=='S')
                    {
                        sx=i;
                        sy=j;
                        sz=k;
                        break;
                    }
                }
            }
        }
        bfs();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值