Dungeon Master POJ - 2251

题目链接:Dungeon Master POJ - 2251

===================================================

Dungeon Master

Time Limit: 1000MS
Memory Limit: 65536K

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S…
.###.
.##…
###.#

##.##
##…

#.###
####E

1 3 3
S##
#E#

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source:Ulm Local 1997

===================================================

算法:BFS

思路:

  • 在于三维的迷宫 用三维状态函数

===================================================

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

int l,r,c;
char ch;
bool fk[31][31][31];
bool cp;

struct node{
    int z,x,y;
    int cc;
};

node k,j;
queue<node> q;

void init(){
    cp=false;
    memset(fk,false,sizeof fk);
    for(int z=1;z<=l;z++)
        for(int x=1;x<=r;x++)
            for(int y=1;y<=c;y++){
                ch=getchar();
                while(ch=='\n') ch=getchar();
                if(ch=='S') k.cc=0,k.x=x,k.y=y,k.z=z;
                if(ch=='E') j.x=x,j.y=y,j.z=z;
                if(ch=='E'||ch=='.') fk[z][x][y]=true;
            }
}

bool check(int z,int x,int y){
    if(z<1||z>l) return false;
    if(x<1||x>r) return false;
    if(y<1||y>c) return false;
    if(fk[z][x][y]) return true;
    return false;
}

int main()
{
    while(cin>>l>>r>>c){
        if(l==0&&r==0&&c==0) break;
        init();
        q.push(k);
        while(!q.empty()){
            node n = q.front();q.pop();
            if(n.x==j.x&&n.z==j.z&&n.y==j.y) {cout<<"Escaped in "<<n.cc<<" minute(s)."<<endl;cp=true;break;}
            if(check(n.z-1,n.x,n.y)) {node m = n;m.z--;m.cc++;q.push(m);fk[n.z-1][n.x][n.y]=false;}
            if(check(n.z+1,n.x,n.y)) {node m = n;m.z++;m.cc++;q.push(m);fk[n.z+1][n.x][n.y]=false;}
            if(check(n.z,n.x-1,n.y)) {node m = n;m.x--;m.cc++;q.push(m);fk[n.z][n.x-1][n.y]=false;}
            if(check(n.z,n.x+1,n.y)) {node m = n;m.x++;m.cc++;q.push(m);fk[n.z][n.x+1][n.y]=false;}
            if(check(n.z,n.x,n.y-1)) {node m = n;m.y--;m.cc++;q.push(m);fk[n.z][n.x][n.y-1]=false;}
            if(check(n.z,n.x,n.y+1)) {node m = n;m.y++;m.cc++;q.push(m);fk[n.z][n.x][n.y+1]=false;}
        }
        while(!q.empty()) q.pop();
        if(!cp) cout<<"Trapped!"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

盐太郎

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值