[POJ1905]Expanding Rods

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 


Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.


Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 


Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001

-1 -1 -1


Sample Output
61.329
225.020

0.000



题意:
一根细长的长度L被加热到n度时,它会扩展到一个新的长度L ' =(1 + n * C)* L,这里C是热膨胀系数。
当一根细杆安装在两个坚实的墙壁上,然后加热,它就会膨胀,呈圆形的形状,原来的杆子是这个部分的弦。

给出杆的原长、温度和热膨胀系数,计算出杆的中心位移的距离。



题解:
二分距离
勾股定理: (h_max)^2=( newL/2 )^2-( oldL/2 )^2 (其实根本取不到)
勾股定理: r^2=( oldL/2 )^2+( r-midH )^2
r^2=( oldL^2 )/4+( r^2-2*r*midH+midH^2 )
2*r*midH=( oldL^2 )/4+midH^2
r=( oldL^2 )/( 8*midH )+midH/2
弧度制: α=( newL/2 )/r
三角函数: sin(α)=( oldL/2 )/r

反三角函数: α=asin( ( oldL/2 )/r )


通过比较 newL/(2*r) 与 asin( oldL/(2*r) ) 的大小修改upH与downH


再注意一下精度误差等小细节就行了:)


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const double esp=1e-7;
double oldL, newL, n, C;

int main() {
	while( ~scanf( "%lf%lf%lf", &oldL, &n, &C ) ) {
		if( oldL==-1 && n==-1 && C==-1 ) break;
		newL=( 1+n*C )*oldL;
		
		double upH=sqrt( newL*newL-oldL*oldL )/2;
		double downH=0.0;
		
		while( upH-downH>=esp ) {
			double midH=( upH+downH )/2;
			double r=( oldL*oldL )/( 8*midH )+midH/2;
			if( newL/r < 2*asin( oldL/(2*r) ) ) upH=midH;
			else downH=midH;
		}
		printf( "%.3lf\n", upH );
	}
 return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值