[POJ3714]Raid

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input
2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
Sample Output
1.414
0.000
题意:有两类点各n个,求出不同类型的点中的最近点对的距离

题解:以x坐标排序, 划中线分成两堆,递归求每堆的最近距离dis,
暴力计算两堆之间距离p[mid]不超过dis的点,看是否有比dis短的距离

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const double INF=1e50;//尽量开大点
const int N=1e5*2+10;
int T, n;
struct node{ double x, y; bool flg; }p[N],tmp[N];

bool cmpx( node a, node b ) { return a.x<b.x; }
double Abs( double x ) { return x<0 ? (-x) : x; }

double length( node a, node b ) {
	if( a.flg==b.flg ) return INF;
	return sqrt( (a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y) );
}

double Distance( int down, int up ) {
	if( down==up ) return INF;
	if( up-down==1 ) return length( p[down], p[up] );
	int mid=( down+up )>>1, cnt=0;//划中线分成两堆, 递归求每堆的最近距离dis
	double dis=min( Distance( down, mid ), Distance( mid+1, up ) );
	//暴力计算两堆之间距离p[mid]不超过dis的点, 看是否有比dis短的距离
	for( int i=down; i<=up; i++ )
		if( Abs( p[i].x-p[mid].x )<=dis )//x距离已超过的点不可能再比dis短
			tmp[++cnt]=p[i];
	for( int i=1; i<cnt; i++ )
		for( int j=i+1; j<=cnt; j++ )
			if( Abs( tmp[i].y-tmp[j].y )>dis ) break;//y同理
			else dis=min( dis, length( p[i], p[j] ) );
    return dis;
}

int main() {
	for( scanf( "%d", &T ); T; T-- ) {
		scanf( "%d", &n );
		for( int i=1; i<=n; i++ )
			scanf( "%lf%lf", &p[i].x, &p[i].y ), p[i].flg=1;
		for( int i=1; i<=n; i++ )
			scanf( "%lf%lf", &p[i+n].x, &p[i+n].y ), p[i+n].flg=0;
		sort( p+1, p+n*2+1, cmpx );//以x坐标排序
		printf( "%.3lf\n", Distance( 1, n*2 ) );
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值