01-复杂度2 Maximum Subsequence Sum(最大子列和问题变化)

一、题目:

01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

作者: 陈越

单位: 浙江大学

时间限制: 200 ms

内存限制: 64 MB

二、代码

本人代码并没有拿到测试满分(25),只拿到23分,测试点2并列和对应相同i但是不同j,即尾是0这个测试点没有通过。我一直没有找到例子和代码的错误,希望看懂的发我测试样例,后期更新

#include<iostream>
using namespace std;
void MaxSubsequenceSum(int A[],int N)
{
	int flag = 0;  //flag标志量 
	int ThisSum = 0, MaxSum = 0;  //当前和,序列最大和 
	int start = 0, end = 0,count = 0;   //保留起点和终点 
	for(int i = 0;i < N; i++)     //判断全是负数 
	{	
		if(A[i] < 0)
			count++;
		if(count == N)
		{
			cout <<0<<" "<<A[0]<<" "<<A[N-1];
			return;
		}
	}    
	//在线处理算法 
	for(int i = 0;i < N; i++)
	{
		ThisSum = ThisSum + A[i]; 
		if(ThisSum < 0)
		{
			ThisSum = 0;
			if(!flag)             // 这个标志量主要用于start,标志是否丢弃前面ThisSum 
				flag = 1;
			if(A[i + 1] == 0)    //判断当前ThisSum<0并且下一个数为零的情况,对start和end更新 
				{
					flag = 0;
					end = start = i + 1;	
					
				}	
		}
		if(ThisSum > MaxSum)
		{
			if(flag)
			start = i;
			MaxSum = ThisSum;
			end = i;
			flag = 0;		//每次更新完start、end后,重置标志变量 
		}
	}
		cout<<MaxSum<<" "<<A[start]<<" "<<A[end];
}
int main()
{
		int n;
		cin>>n;
		int *A = new int[n];
		for(int i = 0;i < n;i++)
			cin>>A[i];
		MaxSubsequenceSum(A,n); 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值