树的直径

Cow Marathon

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 6224 Accepted: 2989
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

首先,对任意一个点进行BFS,找到离他最远的点,再对这个最远点BFS,找到最远距离。 

#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
const int maxn=100020;
using namespace std;
int dis[maxn],ans;
bool vis[maxn];
vector<pair<int,int> > V[maxn];
int bfs(int x)
{
    memset(dis,0,sizeof(dis));
    memset(vis,0,sizeof(vis));
    queue<int>Q;
    Q.push(x);
    vis[x]=1;
    int point=0;
    while(!Q.empty())
    {
        int F=Q.front();
        Q.pop();
        if(dis[F]>ans)
        {
            ans=dis[F];
            point=F;
        }
        pair<int,int>t;
        for(int i=0;i<V[F].size();i++)
        {
             t=V[F][i];
             if(vis[t.first]==0)
             {
                vis[t.first]=1;
                dis[t.first]=dis[F]+t.second;
                Q.push(t.first);
             }
        }
    }
    return point;
}
int main()
{
    int N,M,x,y,z;
    char dir;
    while(cin>>N>>M)
    {
        for(int i=0;i<M;i++)
        {
            cin>>x>>y>>z>>dir;
            V[x].push_back(make_pair(y,z));
            V[y].push_back(make_pair(x,z));
        }
        ans=0;
        int point=bfs(1);
        ans=0;
        bfs(point);
        cout<<ans<<endl;
        for(int i=0;i<=N;i++)
            V[i].clear();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值