HDU 2822 Dogs(优先队列)

Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim’s), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend’s home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).
Input
The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with ‘X’ stands for the lattices of house, and ‘.’ stands for the empty land. The following two lines is the start and end places’ coordinates, we guarantee that they are located at ‘X’. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.
Output
For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.
Sample Input
6 6
..X…
XXX.X.
….X.
X…..
X…..
X.X…
3 5
6 3

0 0
Sample Output
3

Hint
Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).

题意:
意思是这样的:给出n,m表示图的范围。然后给出图。给出起点坐标。给出终点坐标。走X不增加步数,走.增加一步。问从起点到终点最少多少步。

解题思路:优先队列需要认真学习呀。。

定义优先队列按步数从小到大排序,注意重载符应该是>号。

这样在每一步往下扩展的时候,步数少的那个点先出队列,这样bfs到终点时即为最少步数。

定义好优先队列就正常bfs啦,他会自动按步数最少的格子扩展的。

同时终于体会到用真正的queue和用数组模拟的队列的区别。

因为queue可以使用优先队列啊~~
AC代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

char mp[1010][1010];
int book[1010][1010];
int nx[4][2]={0,1,1,0,0,-1,-1,0};
int x1,x2,y1,y2,n,m;

struct node
{
    int x,y,step;
    bool friend operator < (node a,node b)
    {
        return a.step>b.step;//注意符号
    }
};

int bfs()
{
    priority_queue<node> q;//定义优先队列
    node now,tmp;
    now.x=x1;
    now.y=y1;
    now.step=0;
    book[x1][y1]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==x2&&now.y==y2) return now.step;
        for(int i=0;i<4;i++)
        {
            int tx=now.x+nx[i][0];
            int ty=now.y+nx[i][1];
            int tp=now.step;
            if(tx>=0&&tx<n&&ty>=0&&ty<m&&book[tx][ty]==0)
            {
                tmp.x=tx;
                tmp.y=ty;
                if(mp[tx][ty]=='.') tp++;
                tmp.step=tp;
                book[tx][ty]=1;
                q.push(tmp);
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        memset(book,0,sizeof(book));
        for(int i=0;i<n;i++)
            scanf("%s",mp[i]);
        scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        x1--;y1--;x2--;y2--;//题中给的坐标是从1开始的
        printf("%d\n",bfs());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值