杭电 2822 优先队列+光搜

       是一道搜索题,和NYOJ上的坦克大战非常像,用优先队列+光搜就可以了。个人感觉这道题用dijkstra应该也可以解决,就是建图太麻烦了。题目:

Dogs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1046    Accepted Submission(s): 373


Problem Description
Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).
 

Input
The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.
 

Output
For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.
 

Sample Input
  
  
6 6 ..X... XXX.X. ....X. X..... X..... X.X... 3 5 6 3 0 0
 

Sample Output
  
  
3
Hint
Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).
 
ac代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <string.h>
#include <algorithm>
using namespace std;
#define M 1010
struct point{
  int x,y,step;
  bool operator< (const point&p)const{
    return step>p.step;
  }
}p,newp;
int n,m,visted[M][M],sx,sy,ex,ey;
int addx[4]={1,-1,0,0};
int addy[4]={0,0,1,-1};
int map[M][M];
void init(){
  p.x=sx;p.y=sy;
  p.step=map[sx][sy];
  visted[sx][sy]=1;
}
int bfs(){
  priority_queue<point> qq;
  qq.push(p);
  while(!qq.empty()){
	p=qq.top();
	qq.pop();
	for(int i=0;i<4;++i){
	  int newx=p.x+addx[i];
	  int newy=p.y+addy[i];
	  if(newx>0&&newx<=n&&newy>0&&newy<=m){
	    if(newx==ex&&newy==ey)
			return p.step;
		if(!visted[newx][newy]){
		  newp.x=newx;
		  newp.y=newy;
		  newp.step=map[newx][newy]+p.step;
		  qq.push(newp);
		  visted[newx][newy]=1;
		}
	  }
	}
  }
  return 0;
}
int main(){
	//freopen("1.txt","r",stdin);
	while(scanf("%d%d",&n,&m),n,m){
		char cc;
		memset(map,0,sizeof(map));
		memset(visted,0,sizeof(visted));
		for(int i=1;i<=n;++i){
		  for(int j=1;j<=m;++j)
		  {
			  cin>>cc;
			  if(cc=='X')
				  map[i][j]=0;
			  else
				  map[i][j]=1;
		  }
		}
		scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
		init();
		int x=bfs();
		printf("%d\n",x+map[ex][ey]);
	}
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值