POJ3259 Wormholes(多种方法检测负权回路bellman-ford,spfa以及floyd)

142 篇文章 3 订阅

 

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

 

 

题意:每组数据先给出m条正权边再给出w条负权边,其中正权边是双向的而负权边是单向的,判断是否存在负权回路。

解题思路:Bellman-Ford解决负权边。

其原理是:对于n个点的图来说,最多只能进行n-1轮松弛就能找到最短路径,如果在进行n-1轮松弛后仍能继续成功松弛,那么此图必然存在负权回路。

Bellman-Ford算法经常会在未达到n-1轮松弛前就已经计算出最短路。所以添加check用来标记数组dis在本轮松弛中是否发生了变化,如果没有发生变化说明松弛结束,提前跳出循环。

 

AC代码:

 

#include<stdio.h>
#define INF 0x3f3f3f3f

int dis[510],n,m,w;

struct edge
{
	int s,e,t;
} e[2710];

void bellman()
{
	int flag,check;
	for(int i=1;i<=n;i++)
		dis[i]=INF;
	for(int k=1;k<=n-1;k++)
	{
		check=0;
		for(int i=1;i<=m;i++)//双向路
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
			if(dis[e[i].e]+e[i].t<dis[e[i].s])
			{
				dis[e[i].s]=dis[e[i].e]+e[i].t;
				check=1;
			}
		}
		for(int i=m+1;i<=m+w;i++)//单向路 
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
		}
		if(check==0) break;
	}
	flag=0;
	for(int i=1;i<=m;i++)//判断是否存在负权回路 
	{
		if(dis[e[i].s]+e[i].t<dis[e[i].e]) flag=1;
	}
	if(flag) printf("YES\n");
	else printf("NO\n");
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&w);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
		}
		for(int i=m+1;i<=m+w;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
			e[i].t=-e[i].t;//转换为负数表示负权
		}
		bellman();
	}
	return 0;
}

 

11.18重开这道题 再补充两个方法。

 

SPFA(队列优化的Bellman-Ford),其原理是如果某个点进入队列的次数超过n次,那么这个图则肯定存在负环。

AC代码:

//spfa
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
#define INF 0x3f3f3f3f

int n, head[505], dist[505];
int tot, ans[505], book[505];

struct node
{
    int v, cost;
    int next;
} edge[5210];

int spfa()
{
    memset(book,0,sizeof(book));
    memset(ans,0,sizeof(ans));
    memset(dist,INF,sizeof(dist));
    dist[1] = 0;
    book[1] = 1;
	
    queue<int>Q;
    Q.push(1);
    ans[1]++;
    while( !Q.empty() )
    {
        int u = Q.front();
        
        Q.pop();
        for( int k = head[u]; k != -1; k = edge[k].next )
        {
            int v = edge[k].v;
            int cost = edge[k].cost;
            if( dist[v] > dist[u] + cost )
            {
            	dist[v] = dist[u] + cost;
            	if( !book[v] )
            	{
            		//printf("v============%d\n",v);
                	book[v] = 1;
                	ans[v]++;
                	Q.push(v);
                	if( ans[v] >= n )
                	{
                		//printf("v===%d\n",v);
                		return 1;
					}
            	}
			}
                
        }
		book[u] = 0;
    }
    return 0;
}

void addedge( int u, int v, int w )
{
    edge[tot].v = v;
    edge[tot].cost = w;
    edge[tot].next = head[u];
    head[u] = tot++;
}

int main()
{
    int T;
    scanf("%d",&T);
    while( T-- )
    {
        memset(head,-1,sizeof(head));
        int m, w, t1, t2, t3;
        scanf("%d%d%d",&n,&m,&w);
        tot = 0;
        for( int i = 0; i < m; i++ )
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            addedge(t1,t2,t3);
            addedge(t2,t1,t3);
        }
        for( int i = 0; i < w; i++ )
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            addedge(t1,t2,-t3);
        }
        if( spfa() )
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;//
}

Floyd,这个就比较好看出来了。

AC代码:
 

//Floyd
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<iostream>  
using namespace std;  
int map[505][505],n,m,k;  
int floyd()  
{  
    for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{  
            for(int j=1;j<=n;j++)  
            {    
                if(map[i][j]>map[i][k]+map[k][j]) map[i][j]=map[i][k]+map[k][j];
            }
            if(map[i][i]<0) return 1;  
    	} 
	}    
    return 0;  
}  
int main()  
{  
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
          
        scanf("%d%d%d",&n,&m,&k);
        
        memset(map,0x3f3f3f3f,sizeof(map));
        for(int i=1;i<=n;i++)map[i][i]=0; 
        
		int a,b,c;
        for(int i=1;i<=m;i++)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            if(c<map[a][b])map[a][b]=map[b][a]=c;  
        }  
        for(int i=1;i<=k;i++)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            map[a][b]=-c;  
        }   
        int f=floyd();  
        if(!f)printf("NO\n");  
        else printf("YES\n");  
    }  
    return 0;  //
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值