POJ2240 Arbitrage(Floyd模板)

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No


题意:意思差不多就是倒票。给出几种货币的名字,再给出几种货币之间的转化关系,问你通过转化能不能使一开始的钱增值。

解题思路:由于数据较小,比较傻瓜的采用了floyd把所有最短路都求了一遍,在这里的最短路并不是指数值的最小,依据题意应该是数值大的话才“松弛”。初始时i到i的距离初始为1,其余的初始为0

为了方便,使用map数组一一对应货币名字和下标。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<map>
using namespace std;

double e[35][35];
int n;

void floyd()
{
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				if(e[i][k]*e[k][j]>e[i][j])
					e[i][j]=e[i][k]*e[k][j];
}

int main()
{
	int tt=1;
	map<string,int> mm;
	string u,v;
	double p;
	
	while(~scanf("%d",&n)&&n)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(i==j) e[i][j]=1;
				else e[i][j]=0;
			}
		}
		
		for(int i=1;i<=n;i++)
		{
			cin>>u;
			mm[u]=i;
		}
		
		int m;
		scanf("%d",&m);
		for(int i=1;i<=m;i++)
		{
			cin>>u>>p>>v;
			e[mm[u]][mm[v]]=p;
		}
		
		floyd();
		int flag=0;
		for(int i=1;i<=n;i++)
		{
			if(e[i][i]>1)
			{
				flag=1;
				break;
			}
		}
		printf("Case %d: ",tt++);
		if(flag) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值