杭电 acm 2057 A+B Again

A + B Again
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33409    Accepted Submission(s): 13551






Problem Description


There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !


 




Input


The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.


 




Output


For each test case,print the sum of A and B in hexadecimal in one line.




 




Sample Input


+A -A
+1A 12
1A -9
-1A -12
1A -AA




 




Sample Output


0
2C
11
-2C
-90




 




Author


linle


 
#include<iostream>
#include<cstring>
#include<string.h>
#include<string>
#include<stdio.h>
using namespace std;
int main()
{
	__int64 a,b;
	while(cin>>hex>>a>>hex>>b)
	{
		a=a+b;
		if(a<0)
		{
		a=-a;
		printf("-%I64X",a);
	}
	else
		printf("%I64X",a);
		cout<<endl;
	}
	return 0; 
}

本来看到15位觉着高精度,后来看到暑假做的计算器里面的十六进制加法,用了输入输出的转换。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值