杭电 acm 2054 A==B?

A == B ?
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 118729    Accepted Submission(s): 18964






Problem Description


Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".


 




Input


each test case contains two numbers A and B.




 




Output


for each case, if A is equal to B, you should print "YES", or print "NO".


 




Sample Input


1 2
2 2
3 3
4 3




 




Sample Output


NO
YES
YES
NO




 




Author


8600 && xhd


#include<iostream>
#include<string.h>
#include<string>
using namespace std;
int spt(char x[])
{
	for(int i=0;x[i]!=0;i++)
	{
		if(x[i]=='.')
		return 1;
	}
	return 0;
}
void zero(char x[],int y)
{
	if(spt(x))
	{
		int l=y-1;
		while(x[l]=='0')
		{
			x[l]=0;
			l--;
		}
		if(x[l]=='.')
		{
			x[l]=0;
			l--;
		}
		y=l;
	}
}
int main()
{
   char a[100000],b[100000];
    while(cin>>a>>b)
    {
         	int l1=strlen(a),l2=strlen(b);
         	zero(a,l1);
         	zero(b,l2);
         	if(strcmp(a,b)==0)
         	cout<<"YES"<<endl;
         	else
         	cout<<"NO"<<endl;
	}
	return 0;
}   
这个刚开始看着好容易,wa了一次发现没那么简单,要判断是否有小数点以及小数点后面的0,如果是12.20000那么就将2后面的0全部去掉,再进行字符串比较即strcmp()





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值