UVALive 2031 Dance Dance Revolution



Description

Download as PDF

Mr. White, a fat man, now is crazy about a game named ``Dance, Dance, Revolution". But his dance skill is so poor that he could not dance a dance, even if he dances arduously every time. Does ``DDR" just mean him a perfect method to squander his pounds? No way. He still expects that he will be regarded as ``Terpsichorean White" one day. So he is considering writing a program to plan the movement sequence of his feet, so that he may save his strength on dancing. Now he looks forward to dancing easily instead of sweatily.

``DDR" is a dancing game that requires the dancer to use his feet to tread on the points according to the direction sequence in the game. There are one central point and four side points in the game. Those side points are classified as top, left, bottom and right. For the sake of explanation, we mark them integers. That is, the central point is 0, the top is 1, the left is 2, the bottom is 3, and the right is 4, as the figure below shows:

\epsfbox{p2031.eps}

At the beginning the dancer's two feet stay on the central point. According to the direction sequence, the dancer has to move one of his feet to the special points. For example, if the sequence requires him to move to the top point at first, he may move either of his feet from point 0 to point 1 (Note: Not both of his feet). Also, if the sequence then requires him to move to the bottom point, he may move either of his feet to point 3, regardless whether to use the foot that stays on point 0 or the one that stays on point 1.

There is a strange rule in the game: moving both of his feet to the same point is not allowed. For instance, if the sequence requires the dancer to the bottom point and one of his feet already sta ys on point 3, he should stay the very foot on the same point and tread again, instead of moving the other one to point 3.

After dancing for a long time, Mr. White can calculate how much strength will be consumed when he moves from one point to another. Moving one of his feet from the central point to any side points will consume 2 units of his strength. Moving from one side point to another adjacent side point will consume 3 units, such as from the top point to the left point. Moving from one side point to the opposite side point will consume 4 units, such as from the top point to the bottom point. Yet, if he stays on the same point and tread again, he will use 1 unit.

Assume that the sequence requires Mr. White to move to point 1 $ \rightarrow$ 2 $ \rightarrow$ 2 $ \rightarrow$ 4. His feet may stays on (point 0, point 0) $ \rightarrow$ (0, 1) $ \rightarrow$ (2, 1) $ \rightarrow$ (2, 1) $ \rightarrow$ (2, 4). In this couple of integers, the former number represents the point of his left foot, and the latter represents the point of his right foot. In this way, he has to consume 8 units of his strength. If he tries another pas, he will have to consume much more strength. The 8 units of strength is the least cost.

Input

The input file will consist of a series of direction sequences. Each direction sequence contains a sequence of numbers. Ea ch number should either be 1, 2, 3, or 4, and each represents one of the four directions. A value of 0 in the direction sequence indicates the end of direction sequence. And this value should be excluded from the direction sequence. The input file ends if the sequence contains a single 0.

Output

For each direction sequence, print the least units of strength will be consumed. The result should be a single integer on a line by itself. Any more white spaces or blank lines are not allowable.

Sample Input

1 2 2 4 0 
1 2 3 4 1 2 3 3 4 2 0 
0

Sample Output

8 
22
思路:我们用dp[i][j][k]表示在第i步,舞者的左脚在j,右脚在k所耗费的最少能量。
状态转移式:dp[i][a[i]][k]=min(dp[i][a[i]][k],dp[i][j][k]+cost[j][a[i]]);
            dp[i][j][a[i]]=min(dp[i][j][a[i]],dp[i][j][k]+cost[a[i]][k]);
另外两脚不能同时在一个格子中注意下
#include <iomanip>
#include <map>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstdio>
using namespace std;
const int inf=1e8+10;
#define LL long long 
const int maxn=1e5+10;
int dp[maxn][10][10],a[maxn],cost[10][10];
int main()
{
	for(int i=1;i<=4;i++){
		cost[0][i]=2;
		cost[i][i]=1;
	}
	for(int i=1;i<=3;i++){
		cost[i][i+1]=3;
		cost[i+1][i]=3;
	}
	cost[4][1]=cost[1][4]=3;
	for(int i=1;i<=2;i++){
		cost[i][i+2]=cost[i+2][i]=4;
	}
	int st;
	while(scanf("%d",&st)&&st){
		int cnt=0;
		a[++cnt]=st;
		while(scanf("%d",&st)&&st){
			a[++cnt]=st;
		}
		for(int i=1;i<=cnt;i++){
			for(int j=0;j<=4;j++){
				for(int k=0;k<=4;k++){
					dp[i][j][k]=inf;
				}
			}
		}
		dp[1][a[1]][0]=cost[0][a[1]];
		dp[1][0][a[1]]=cost[0][a[1]];
		for(int i=2;i<=cnt;i++){
			for(int j=0;j<=4;j++){
				for(int k=0;k<=4;k++){
					if(dp[i-1][j][k]==inf) continue;
					if(a[i]==k||j==a[i]){
						dp[i][j][k]=min(dp[i][j][k],dp[i-1][j][k]+1);
						continue;
					}
					dp[i][a[i]][k]=min(dp[i][a[i]][k],dp[i-1][j][k]+cost[j][a[i]]);
					dp[i][j][a[i]]=min(dp[i][j][a[i]],dp[i-1][j][k]+cost[k][a[i]]);
				}
			}
		}
		int ans=inf;
		for(int i=1;i<=4;i++){
			ans=min(ans,dp[cnt][i][a[cnt]]);
			ans=min(ans,dp[cnt][a[cnt]][i]);
		}
		cout<<ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值