1106 Persistence

1106: Persistence
Consider the series of numbers where each term is the product of the decimal digits of the previous term. Eventually the term will be reduced to a single digit.
For example start with 679:
在这里插入图片描述
(图错了一点)
The number of steps this takes is called the Persistence of a number. Thus, the persistence of 679 is 5, since that’s number of steps it took to get to a single digit number.
输入
Each input will consist of a single test case. Note that your program may be run multiple times on different inputs. The input will consist of a single line, with a positive number of up to 9 decimal digits with no leading zeros.
输出
For each test case, output a single integer, representing the persistence of the input number; that is, the number of steps necessary to reduce it to a single digit.
样例输入 Copy
5
样例输出 Copy
0

一个水题吧,写了两个函数调用一下

#include <bits/stdc++.h>
using namespace std;
int ji(int n)
{
    int num=1;
    while(n!=0)
    {
        num=num*(n%10);
        n=n/10;
    }
    return num;
}
int cal(int n)
{
    int num=ji(n);
    int cnt;
    if(n>=10)
    {
        cnt=1;
    }
    else
    {
        cnt=0;
    }
    while(num>=10)
    {
        cnt++;
        num=ji(num);
    }
    return cnt;
}

int main()
{
    int n,cnt;
    cin>>n;
    cnt=cal(n);
    cout<<cnt;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值