POJ 2106 Boolean Expressions(模拟+LL1)

19 篇文章 0 订阅

Description
判断公式的F或V
Input
多组用例,每组用例为以字符串表示公式,以文件尾结束输入
Output
对于每组用例,输出公式的结果F or V
Sample Input
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))
Sample Output
Expression 1: F
Expression 2: V
Expression 3: V
Solution
模拟,用LL1
Code

#include<iostream>
#include<string>
using namespace std;
string rep[14][2]= 
{
    " ","",
    "!!","",
    "(V)","V",
    "(F)","F",
    "!V","F",
    "!F","V",
    "V&V","V",
    "V&F","F",
    "F&V","F",
    "F&F","F",
    "V|V","V",
    "V|F","V",
    "F|V","V",
    "F|F","F"
};
string s;
int main()
{
    int i,t,count=1;
    while(getline(cin,s))
    {
        while(1)
        {
            for(i=0;i<14;i++)
                if((t=s.find(rep[i][0]))!=string::npos)
                {
                    s.erase(t,rep[i][0].length());
                    s.insert(t,rep[i][1]);
                    break;
                }
            if(i==14) break;
        }
        cout<<"Expression "<<count++<<": "<<s<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值