Description
给出一些字符串,将这些字符串中所有的单词反序后输出转化后的字符串
Input
第一行为用例组数T,每组用例占一行为一字符串
Output
对于每组用例,输出转化后的字符串
Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.
Solution
简单字符串处理,注意ungetc函数的使用,这个函数是将读入的一个或多个字符退回到输入流中
Code
#include<stdio.h>
#include<string.h>
char word[1005];
int main()
{
int n;
scanf("%d",&n);
while(scanf("%s",word)!=EOF)
{
for(int i=strlen(word)-1;i>=0;i--)
putchar(word[i]);
char c;
while(c=getchar(),c ==' '||c=='\t'||c=='\n')//空格/跳格/换行字符直接输出
putchar(c);
ungetc(c,stdin);//将读入的字符退回
}
return 0;
}